zoukankan      html  css  js  c++  java
  • POJ2559 Largest Rectangle in a Histogram (单调栈

                  Largest Rectangle in a Histogram

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 26012   Accepted: 8416

    Description

    A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 

    Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

    Input

    The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integersh1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

    Output

    For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

    Sample Input

    7 2 1 4 5 1 3 3
    4 1000 1000 1000 1000
    0
    

    Sample Output

    8
    4000
    

    Hint

    Huge input, scanf is recommended.
     
    代码如下:
    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<queue>
    #include<cstring>
    #include<stack>
    using namespace std;
    const int maxn = 1e5+5;
    int a[maxn];
    int s[maxn];
    int w[maxn];
    int top;
    int main(){
        int n;
        while(scanf("%d",&n),n){
            memset(a,0,sizeof(a));
            memset(s,0,sizeof(s));
            memset(w,0,sizeof(w));
            for(int i=1;i<=n;i++){
                scanf("%d",&a[i]);
            }
            int p=0;
            long long ans=0;
            a[n+1]=0;
            for(int i=1;i<=n+1;i++){
                if(a[i]>s[p]){
                    s[++p]=a[i];
                    w[p]=1;
                }else{
                    int width=0;
                    while(s[p]>a[i]){
                        width+=w[p];
                        ans=max(ans,(long long)width*s[p]);
                        p--;
                    }
                    s[++p]=a[i];
                    w[p]=width+1;
                }
            }
            cout<<ans<<endl;
        }
    }
    View Code
    每一个不曾刷题的日子 都是对生命的辜负 从弱小到强大,需要一段时间的沉淀,就是现在了 ~buerdepepeqi
  • 相关阅读:
    Assembly Manifest 通俗简易手册
    CruiseControl服务器安装配置
    关于URL编码
    从A到Z来说说Web开发
    通过注册表查看 .NET Framework的版本信息
    云数据存在哪里?
    C#中你可能不知道的8件事(zz)
    用PBKDF2 或BCrypt 来存储密码
    C++编译器什么时候为我们自动生成拷贝构造函数?
    C#中你可能不知道的8件事(zz)
  • 原文地址:https://www.cnblogs.com/buerdepepeqi/p/9452942.html
Copyright © 2011-2022 走看看