zoukankan      html  css  js  c++  java
  • [PTA] PAT(A) 1008 Elevator (20 分)

    Problem

    portal: 1008 Elevator (20 分)

    Description

     The highest building in our city has only one elevator. A request list is made up with $N$ positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

     For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    ## Input

    Each input file contains one test case. Each case contains a positive integer $N$, followed by $N$ positive numbers. All the numbers in the input are less than 100.

    ## Output

    For each test case, print the total time on a single line.

    ## Sample ### Sample Input ```cpp 3 2 3 1 ``` ### Sample Output ```cpp 41 ```

    Solution

    Analysis

     电梯向上走一层需要6s,向下走一层需要4s,每一次停止时停留5s,最开始电梯是在第0层,结束后电梯无需返回底层。所以在给出了列表之后,只需要判断电梯是向上还是向下,然后用对应的楼层差值乘所需要的时间,便是电梯移动需要的时间花费,最后加上停留需要的时间,将列表中的每一个楼层都处理完,便是整体所需要的时间。

    Code

    #include <bits/stdc++.h>
    using namespace std;
    
    int main(void) {
    	int n, last, now; // last是上一次停留的楼层, now是这次要去的楼层
    	int result = 0;
    
    	cin >> n; 
    	last = 0;
    	for (int i = 0; i < n; i++) {
    		cin >> now;
    		if (now > last) { // 此时电梯向上运动
    			result += 6 * (now - last) + 5;
    		} else { // 此时电梯向下运动
    			result += 4 * (last - now) + 5;
    		}
    		last = now; // 当前停留楼层更新
    	}
    	cout << result << endl;
    }
    
  • 相关阅读:
    STM32 时钟配置分析
    STM32 开发板资源梳理
    STM32 摄像头实验OV2640
    STM32 TFT液晶屏与FSMC
    STM32 开发板电源与供电方式
    视觉里程计07 Qt的一些bug修改记录
    解决wireshark检测不到网卡的问题
    gdb 脚本调试
    [转] GCC 中的编译器堆栈保护技术
    使用gdbserver远程调试
  • 原文地址:https://www.cnblogs.com/by-sknight/p/11444492.html
Copyright © 2011-2022 走看看