zoukankan      html  css  js  c++  java
  • 深搜+剪枝 POJ 1724 ROADS

    POJ 1724 ROADS

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 12766   Accepted: 4722

    Description

    N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
    Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 

    We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has. 

    Input

    The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
    The second line contains the integer N, 2 <= N <= 100, the total number of cities. 

    The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 

    Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 
    • S is the source city, 1 <= S <= N 
    • D is the destination city, 1 <= D <= N 
    • L is the road length, 1 <= L <= 100 
    • T is the toll (expressed in the number of coins), 0 <= T <=100

    Notice that different roads may have the same source and destination cities.

    Output

    The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
    If such path does not exist, only number -1 should be written to the output. 

    Sample Input

    5
    6
    7
    1 2 2 3
    2 4 3 3
    3 4 2 4
    1 3 4 1
    4 6 2 1
    3 5 2 0
    5 4 3 2
    

    Sample Output

    11
    #include<iostream>
    using namespace std;
    #include<cstdio>
    #include<cstring>
    #define N 105
    #define R 10005
    #define inf (1<<31)-1
    struct Edge{
        int v,last,lenth,val;
    }edge[R];
    int topt=0,head[N],k,n,r,q;
    bool vis[N]={0};
    int ans;
    void input()
    {
        scanf("%d%d%d",&k,&n,&r);
        for(int i=1;i<=r;++i)
        {
            scanf("%d%d%d%d",&q,&edge[i].v,&edge[i].lenth,&edge[i].val);
            edge[i].last=head[q];
            head[q]=i;
        }
    }
    void dfs(int u,int cost,int len)
    {
        if(cost>k||len>=ans) return;
        if(u==n)
        {
            ans=min(ans,len);
            return;
        }
        for(int l=head[u];l;l=edge[l].last)
        {
            if(vis[edge[l].v]) continue;
            vis[edge[l].v]=true;
            dfs(edge[l].v,cost+edge[l].val,len+edge[l].lenth);
            vis[edge[l].v]=false;
        }
    }
    int main()
    {
        input();
        ans=inf;
        dfs(1,0,0);
        if(ans==inf) printf("-1");
        else printf("%d",ans);
        return 0;
    }
  • 相关阅读:
    从yield关键字看IEnumerable和Collection的区别
    Windows Azure Developer Guidance Map(含PDF下载)
    关于CLR内存管理一些深层次的讨论[上篇]
    关于CLR内存管理一些深层次的讨论[下篇]
    当你的博客文章的作者变成“编辑整理”,你作何感想?
    我看周马,以及3Q大战背后的社会问题
    一个完整的用于追踪数据改变的解决方案
    与VS集成的若干种代码生成解决方案[博文汇总(共8篇)]
    如果在BackgroundWorker运行过程中关闭窗体…
    采用一个自创的"验证框架"实现对数据实体的验证[扩展篇]
  • 原文地址:https://www.cnblogs.com/c1299401227/p/5582088.html
Copyright © 2011-2022 走看看