zoukankan      html  css  js  c++  java
  • (杭电 1014)Uniform Generator

    Uniform Generator

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 35190 Accepted Submission(s): 14002

    Problem Description

    Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

    seed(x+1) = [seed(x) + STEP] % MOD

    where '%' is the modulus operator.

    Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

    For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

    If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

    Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

    Input

    Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).

    Output

    For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.

    Sample Input

    3 5
    15 20
    63923 99999
    

    Sample Output

             3         5    Good Choice
    
            15        20    Bad Choice
    
         63923     99999    Good Choice
    

    本题目就是利用所给递推关系式求出的各项结果是否在[0,MOD-1]之间且没有重复(题目有点长,第一次看题有点迷......)

    代码样例

    #include <bits/stdc++.h>
    using namespace std;
    
    int seed[100001];
    int main()
    {
    	int n,m;
    	while(cin>>n>>m)
    	{
            int i;
    		seed[0]=0;
    		for(i=1; i < m; i++)
    			seed[i]=(seed[i-1]+n)%m;
    		sort(seed,seed+m);
    		for(i=0;i<m;i++)
    			if(seed[i] != i)
    				break;
    		printf("%10d%10d",n,m);
    		if(i == m)
    			cout<<"    Good Choice"<<endl<<endl;
    		else
    			cout<<"    Bad Choice"<<endl<<endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    我从来没有想要去
    微信公众号开发系列-发展模式,创建自己的自定义菜单
    iOS6之后 NSAttributedString 福利
    iOS 面试题:OC标题的基本概念&lt;延续&gt;
    逻辑、认识论和本体论“三统一”
    C++中的头文件和源文件
    extern与头文件(*.h)的区别和联系
    Predicate Format String Syntax 与字面量
    编码、格式与网络通信
    充分条件和必要条件的联系和区别是什么
  • 原文地址:https://www.cnblogs.com/cafu-chino/p/10134968.html
Copyright © 2011-2022 走看看