zoukankan      html  css  js  c++  java
  • PAT 甲级 1034 Head of a Gang (30 分)(bfs,map,强连通)

    1034 Head of a Gang (30 分)
     

    One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threthold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

    Name1 Name2 Time
    

    where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

    Output Specification:

    For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

    Sample Input 1:

    8 59
    AAA BBB 10
    BBB AAA 20
    AAA CCC 40
    DDD EEE 5
    EEE DDD 70
    FFF GGG 30
    GGG HHH 20
    HHH FFF 10
    

    Sample Output 1:

    2
    AAA 3
    GGG 3
    

    Sample Input 2:

    8 70
    AAA BBB 10
    BBB AAA 20
    AAA CCC 40
    DDD EEE 5
    EEE DDD 70
    FFF GGG 30
    GGG HHH 20
    HHH FFF 10
    

    Sample Output 2:

    0

    题意:

    给定n条记录(注意不是n个人的记录),两个人之间的关系的权值为这两个人之间所有电话记录的时间之和。

    一个连通块的权值为所有关系权值之和。

    如果一个连通块节点数大于2,且权值大于给定的k,称这是一个gang,拥有关系权值和最多的人是gang的头。

    要求输出gang的数量,每个gang的头,每个gang的人数。按照gang的头的字典序排序。

    题解:

    bfs求连通块。有几个注意点:

    1、给定的是n条记录,n<=1000, 这说明人数应该是2000以内而不是1000以内。否则会测试点3运行时错误。

    2、每一条记录都要考虑,bfs时不能仅判断这个节点是否被访问,还应该设置边的vis数组。

    错误点:

    1、忘记排序,测试点2,5答案错误,否则会测试点3运行时错误

    2、n<=1000, 这说明人数应该是2000以内而不是1000以内

    AC代码:

    #include<iostream>
    #include<algorithm>
    #include<vector>
    #include<queue>
    #include<map>
    #include<string>
    #include<cstring>
    using namespace std;
    map<string,int>m1;
    map<int,string>m2;
    vector<int>v[2005];//给定的是n条记录,n<=1000, 这说明人数应该是2000以内而不是1000以内。测试点3运行时错误
    int ok[2005];//标记有没有被访问过
    struct node{//存储最终答案
        string head;
        int num;
    }ans[2005];
    int w[2005];//计算每个点的权重
    int n,minw;
    queue<int>q;
    int k=1;//map里的个数
    int ans_num=0;//答案个数
    bool cmp(node x,node y){
        return x.head<y.head;
    }
    void bfs(int x){
        int w_sum=0;//计算总权重
        int num=0;//计算人数
        int max_w=w[x];
        int head=x;
        q.push(x);
        ok[x]=1;//标记有没有被访问过
        num++;
        w_sum+=w[x];
        while(!q.empty()){
            int a=q.front();
            q.pop();
            for(int i=0;i<v[a].size();i++){
                int b=v[a].at(i);
                if(ok[b]) continue;
                if(max_w<w[b]){//找出权重的为头目 
                    head=b;
                    max_w=w[b];
                }
                ok[b]=1;
                q.push(b);
                w_sum+=w[b];
                num++;
            }
        }
        w_sum/=2;
        if(num>=3 && w_sum>minw){
            //cout<<"答案:num"<<num<<" "<<m2[head]<<" "<<ans_num<<" w_sum "<<w_sum<<endl;
            node answer;
            answer.num=num;
            answer.head=m2[head]; 
            ans[++ans_num]=answer; 
        }    
    }
    int main(){
        cin>>n>>minw;
        memset(w,0,sizeof(w));
        memset(ok,0,sizeof(ok));
        for(int i=1;i<=n;i++){
            if(!v[i].empty()) v[i].clear();
        } 
        for(int i=1;i<=n;i++){
            string na1,na2;
            int ww;
            cin>>na1>>na2>>ww;
            if(!m1[na1]) {
                m2[k]=na1;
                m1[na1]=k++;
            }
            if(!m1[na2]) {
                m2[k]=na2;
                m1[na2]=k++;
            }
            w[m1[na1]]+=ww;
            w[m1[na2]]+=ww;
            v[m1[na1]].push_back(m1[na2]);
            v[m1[na2]].push_back(m1[na1]);
        }
        for(int i=1;i<=n;i++){
            if(!ok[i]){
                bfs(i);
            }
        }
        cout<<ans_num<<endl;
        sort(ans+1,ans+1+ans_num,cmp);//排序,一开始忘记排了
        for(int i=1;i<=ans_num;i++){
            cout<<ans[i].head<<" "<<ans[i].num<<endl;
        }
        return 0;
    }
  • 相关阅读:
    财务报表分析(张新民教授)-第七章 企业财务质量分析
    财务报表分析(张新民教授)-第七章 企业财务质量分析
    财务报表分析(张新民教授)-第七章 企业财务质量分析
    财务报表分析(张新民教授)-第七章 企业财务质量分析
    财务报表分析(张新民教授)-第七章 企业财务质量分析
    财务报表分析(张新民教授)-第七章 企业财务质量分析
    PS
    史上最强视频网站真实地址解析
    jsonp详解
    width:100%缩小窗口时背景图片出现空白bug
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/11419290.html
Copyright © 2011-2022 走看看