zoukankan      html  css  js  c++  java
  • PAT 甲级 1036 Boys vs Girls (25 分)(简单题)

    1036 Boys vs Girls (25 分)
     

    This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's namegenderID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F(female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

    Output Specification:

    For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF​​gradeM​​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

    Sample Input 1:

    3
    Joe M Math990112 89
    Mike M CS991301 100
    Mary F EE990830 95
    

    Sample Output 1:

    Mary EE990830
    Joe Math990112
    6
    

    Sample Input 2:

    1
    Jean M AA980920 60
    

    Sample Output 2:

    Absent
    Jean AA980920
    NA

    题解:

    要注意absent的顺序

    题目大意: 给N个学生的成绩、名字、ID和分数,还有性别(gender)。分别找出男孩子分数最低和女孩子分数最高的,打印名字和ID,然后求两者的成绩差,如果某一方不存在,那么打印Absent,分数差值为NA。

    AC代码:

    #include<bits/stdc++.h>
    using namespace std;
    string nm;
    char ge;
    string id;
    int grade;
    int n;
    int main(){
        int n;
        cin>>n;
        string fn="",mn="";
        string fid,mid;
        int fg=-1,mg=101;
        for(int i=1;i<=n;i++)
        {
            cin>>nm>>ge>>id>>grade;
            if(ge=='F'){
                if(grade>fg){
                    fg=grade;
                    fn=nm;
                    fid=id;
                }
            }
            if(ge=='M'){
                if(grade<mg){
                    mg=grade;
                    mn=nm;
                    mid=id;
                }
            }
        }
        if(fg<0){
            cout<<"Absent"<<endl;//注意absent的顺序
            cout<<mn<<" "<<mid<<endl;
            cout<<"NA";
        }
        else if(mg>100){
            cout<<fn<<" "<<fid<<endl;
            cout<<"Absent"<<endl;//注意absent的顺序
            cout<<"NA"<<endl;
        }else{
            cout<<fn<<" "<<fid<<endl;
            cout<<mn<<" "<<mid<<endl;
            cout<<fg-mg<<endl;
        }
        return 0;
    }
  • 相关阅读:
    BZOJ1257:[CQOI2007]余数之和——题解+证明
    BZOJ3781:小B的询问——题解
    BZOJ2038:[2009国家集训队]小Z的袜子——题解
    BZOJ3052 & UOJ58:[WC2013]糖果公园——题解
    BZOJ1086:[SCOI2005]王室联邦——题解
    BZOJ1878:[SDOI2009]HH的项链——题解
    BZOJ2453:维护队列——题解
    美团新零售招聘-高级测试开发(20k-50k/月)
    Shopee招聘-测试开发leader(30k-60k/月)
    蚂蚁金服招聘-无线测试开发(20k-36k/月)
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/11420731.html
Copyright © 2011-2022 走看看