zoukankan      html  css  js  c++  java
  • PAT 甲级 1144 The Missing Number (20 分)(简单,最后一个测试点没过由于开的数组没必要大于N)

    1144 The Missing Number (20 分)
     

    Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

    Output Specification:

    Print in a line the smallest positive integer that is missing from the input list.

    Sample Input:

    10
    5 -25 9 6 1 3 4 2 5 17
    

    Sample Output:

    7

    题意:

    给你一个序列,让你找一个数x,x是不在这个序列里的最小正整数。

    题解:

    做此题的时候,最后一个测试点老是段错误,仔细查看下数据范围int,如果开一个int范围大小的数组判断,显然不可能,那么就猜下测试数据的范围。最后一个测试点没过由于开的数组没必要大于N。因为总共不会超过100000的数,所以在100002前一定会出现一个最小数没有出现。

    AC代码:

    #include<bits/stdc++.h> 
    using namespace std;
    int n;
    int a[100010];
    int main(){
        cin>>n;
        for(int i=1;i<=n;i++){
            int x;
            cin>>x;
            if(x>0 && x<=100002){
            //总共不会超过100000的数,所以在100002前一定会出现一个最小数没有出现
                a[x]=1;
            }
        }
        for(int i=1;i<=100002;i++){
            if(!a[i]){
                cout<<i;
                break;
            }
        }
        return 0;
    } 
  • 相关阅读:
    Linux下使用Eclipse 远程调试
    关于Mysql分区和分表
    Mysql点滴
    父窗口与iFrame之间调用方法和元素
    pl/sql developer安装使用即时客户端
    Java的四大基础特性
    Get与Post的小知识
    ibatis 中 $与#的区别
    Eclipse安装配置Maven
    Git学习
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/11898561.html
Copyright © 2011-2022 走看看