zoukankan      html  css  js  c++  java
  • PAT 甲级 1070 Mooncake (25 分)(结构体排序,贪心,简单)

    1070 Mooncake (25 分)
     

    Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

    Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤), the number of different kinds of mooncakes, and D(≤ thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

    Sample Input:

    3 200
    180 150 100
    7.5 7.2 4.5
    

    Sample Output:

    9.45

    题意:

    给定N种月饼、月饼的总需求量D以及各种月饼的供应量和总价格,问怎么样销售带来的利润最大。

    题解:

    我统一用double,贪心水题,一遍过。

    AC代码:

    #include<iostream>
    #include<algorithm>
    using namespace std;
    int n;
    double d;
    struct node{
        double w;
        double p;
    }a[1005];
    bool cmp(node x,node y){
        return (x.p/x.w)>(y.p/y.w);
    }
    double s=0;
    int main(){
        cin>>n>>d;
        for(int i=1;i<=n;i++) cin>>a[i].w;
        for(int i=1;i<=n;i++) cin>>a[i].p;
        sort(a+1,a+1+n,cmp);
        
        for(int i=1;i<=n;i++){
            if(a[i].w>=d){
                s+=d/a[i].w*a[i].p;
                d=0;
                break;
            }else{
                d-=a[i].w;
                s+=a[i].p;
            }
            if(d-0<0.00000001){
                break;
            }
        }
        printf("%.2f",s);
        return 0;
    }
  • 相关阅读:
    React元素渲染
    初识JSX
    微信小程序复制文本到剪切板
    微信小程序报错request:fail url not in domain list
    小程序,通过自定义编译条件,模拟推荐人功能
    积分抵扣逻辑
    微信小程序 switch 样式
    tomcat 配置开启 APR 模式
    tomcat8 传输json 报错 Invalid character found in the request target. The valid characters are defined in RFC 3986
    c++数组初始化误区
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/13270616.html
Copyright © 2011-2022 走看看