zoukankan      html  css  js  c++  java
  • PAT 甲级 1067 Sort with Swap(0, i) (25 分)(贪心,思维题)*

    1067 Sort with Swap(0, i) (25 分)
     

    Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

    Swap(0, 1) => {4, 1, 2, 0, 3}
    Swap(0, 3) => {4, 1, 2, 3, 0}
    Swap(0, 4) => {0, 1, 2, 3, 4}
    

    Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

    Input Specification:

    Each input file contains one test case, which gives a positive N (≤) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

    Output Specification:

    For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

    Sample Input:

    10
    3 5 7 2 6 4 9 0 8 1
    

    Sample Output:

    9

    题意:

    给出{0, 1, ..., N−1} 的一个序列,要求通过两两交换的方式将其变为递增序列,但是每一次减缓必须用 0 与其它数进行交换。求最小交换次序。其中, N (≤10^​5​​)。

    题解:

    贪心算法:要求一个问题的最优解,先求局部最优解,即就是中间每一步都要是最优解

    本题中,如果当前 0 处于 i 号位,则找到数字 i 当前所处的位置,然后把 0 与 i 进行交换,此时数字i 就位于它的最终位置上,取得了最优解。

            对于本题很容易想到一个策略:如果当前 0 处于 i 号位,则找到数字 i 当前所处的位置,然后把 0 与 i 进行交换。但是思路存在一个问题:当0处于 0 号位时,将无法继续。因此,处理这个问题,当 0 回到 0 号位时,随意选择一个还没有回到本位的数字与 0 交换,从而继续。

    思考:

            容易想得到直接模拟交换过程,交换的时候cnt++,但是直接交换就算用了map还是测试1和测试2超时,无奈想不出好的方法,但是想到了,可以一开始数有多少个数字不在本本位上,答案按为个数-1,但是要加上有多少次0在交换过程中会被换到0本位,因为还要再换回去。但是具体不会操作,查了网上的题解,看到一个不错的写法,很简洁,方法是我一开始的模拟,但是它只开了一个数组,这个我没有想到。

    比如:4 0 2 1 3

    a[4]=0

    a[0]=1  ** => a[0]=3

    a[2]=2                        =>  4 1 2 0 3

    a[1]=3  ** => a[1]=1

    a[3]=4

    交换0和1的位置,就算交换a[0]和a[a[0]]

    下面对源代码做一点理解分析。外层for循环保证访问到每个元素,内层while(i!=a[i])保证本次访问操作中a[i]元素交换到它最终的位置上,在本次操作中也有可能会顺带将其他元素也交换到它对应的最终位置。访问操作的代码理解,0作为哨兵,首先将0所占的位置最终应该存的元素换回该位置,(a[0]表示0当前所在的位置)(这个操作即为有效操作),这样交换完毕后0会回到0对应的最终位置(即0),此时挑选任一个乱序元素暂存0位置,(这个操作即为无效操作),本算法选择0元素后面第一个乱序元素。
    ————————————————
    版权声明:本文为CSDN博主「virgilshi」的原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接及本声明。
    原文链接:https://blog.csdn.net/whutshiliu/article/details/82952258

    AC代码:

    #include<iostream>
    #include<algorithm>
    #include<map>
    using namespace std;
    int a[100005];
    int n;
    int cnt=0;
    int main(){
        cin>>n;
        for(int i=0;i<n;i++){
            int x;
            cin>>x;
            a[x]=i;
        }
        for(int i=0;i<n;i++){
            if(i!=a[i]){
                while(a[0]!=0){
                    //0所在的位置 和 0所在位置(本位数)所在位置
                    swap(a[0],a[a[0]]);
                    cnt++;
                }
                if(i!=a[i]){
                    swap(a[0],a[i]);
                    cnt++;
                }
            }
        }
        cout<<cnt;
        return 0;
    }

    超时代码:

    #include<iostream>
    #include<algorithm>
    #include<map>
    using namespace std;
    map<int,int>val;//val[x]=y表示第i位置的值为y
    map<int,int>add;//add[x]=y数字y在第i的位置
    int n;
    int con;
    int main(){
        cin>>n;
        con=0;
        for(int i=0;i<n;i++){
            cin>>val[i];
            add[val[i]]=i;//数字a[i]在第i的位置
        }
        int f=-1;
        while(1){
            if(val[0]==0){
                f=-1;
                for(int i=1;i<n;i++){
                    if(val[i]!=i){//存在第i个位置不是i
                        f=i;
                        break;
                    }
                }
                if(f==-1)break;
                con++;
                val[0]=val[f];
                add[val[f]]=0;
                val[f]=0;
                add[0]=f;
            }else{
                con++;
                int x=add[0];
                val[add[x]]=0;
                add[0]=add[x];
                val[x]=x;
                add[x]=x;
            }    
        }
        cout<<con;
        return 0;
    }
    
        
    View Code
  • 相关阅读:
    loadrunner提高篇
    loadrunner提高篇
    loadrunner提高篇
    STM32F4XX高效驱动篇1-UART
    系统封装接口层 cmsis_os
    uCGUI 按键窗口切换机制
    xming+xshell让linux变成桌面化操作
    jmeter做WebSocket请求解读
    性能监控工具spotlight操作
    linux性能监控命令,磁盘,网络,cpu,内存
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/13270623.html
Copyright © 2011-2022 走看看