zoukankan      html  css  js  c++  java
  • PAT 甲级 1031 Hello World for U (20 分)(一开始没看懂题意)

                                   1031 Hello World for U (20 分)

     

    Given any string of N (≥) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

    h  d
    e  l
    l  r
    lowo
    

    That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3 } with n​1​​+n​2​​+n​3​​−2=N.

    Input Specification:

    Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

    Output Specification:

    For each test case, print the input string in the shape of U as specified in the description.

    Sample Input:

    helloworld!
    

    Sample Output:

    h   !
    e   d
    l   l
    lowor
    
    

    题意

    一开始没看懂题意,看懂以后一遍过。

    尽可能围成正方形。在满足n1=n3,且n1<=n2的条件下,n1尽可能地大。

    底部字符数量 n2 最少为3。n1 = n3 要尽量等于 n2 。也就是说,n1 = n3 = (n+2) / 3;因为 '/ 3' 会截掉小数部分,所以 n1 和 n3 总是小于或者等于 n2 。

    AC代码:

    #include<bits/stdc++.h>
    using namespace std;
    char a[105];
    int main(){
        cin>>a;
        int l=strlen(a);
        int n1=(l+2)/3;
        int n2=l-n1*2;
        //cout<<n1<<" "<<n2<<endl;
        for(int i=0;i<n1-1;i++){
            cout<<a[i];
            for(int j=1;j<=n2;j++){
                cout<<" ";
            }
            cout<<a[l-1-i]<<endl;
        }
        for(int i=n1-1;i<=n1+n2;i++){
            cout<<a[i];
        }
        return 0;    
    }
    
     
  • 相关阅读:
    Linux启动ftp服务器530 Permission denied解决方法
    Cloudera的CDH和Apache的Hadoop的区别
    我的vm虚拟机网络设置
    本地Yum软件源安装Cloudera Manager 5
    SSH无法登陆服务器,但是可以ping通,解决方法
    Linux (CentOS)增加删除用户
    SSH创建公钥实现无密码操作失败原因
    chkconfig命令详解
    camon详细解决过程
    @修饰器
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/13270664.html
Copyright © 2011-2022 走看看