zoukankan      html  css  js  c++  java
  • PAT 甲级 1019 General Palindromic Number (进制转换,vector运用,一开始2个测试点没过)...

    1019 General Palindromic Number (20 分)
     

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as (. Here, as usual, 0 for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

    Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

    Input Specification:

    Each input file contains one test case. Each case consists of two positive numbers N and b, where 0 is the decimal number and 2 is the base. The numbers are separated by a space.

    Output Specification:

    For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ ... a​0​​". Notice that there must be no extra space at the end of output.

    Sample Input 1:

    27 2
    

    Sample Output 1:

    Yes
    1 1 0 1 1
    

    Sample Input 2:

    121 5
    

    Sample Output 2:

    No
    4 4 1
    
    

    解题思路
      题目大意:给定一个N和b,求N在b进制下,是否是一个回文数(Palindromic number)。其中,0<N,b<=10^9。
      使用int作为基本类型就足够了,然后进行进制转换,需要注意的是,b进制比较大,可能得到的不是一个单位数,比如16进制下的10~15。可以用char进行存储,然后比较。或者用一个的二维数组进行比较也行。

    但是后来发现用char,数字+'0'可能会超出ascii表示的范围,有一个测试点就是过不去。

    最终选择用vector<int>,很方便。

    典型测试样例:

    6817 16
    Yes
    1 10 10 1
    187521254 1000000
    No
    187 521254

    AC代码:

    #include<bits/stdc++.h> 
    using namespace std;
    int main(){
        int d,b;
        cin>>d>>b;
        char s[1005];
        int k=1;
        while(d>0){
            s[k++]=d%b+'0';
            //cout<<d%b<<endl;
            d=d/b;
        }
        k--; 
        //cout<<d<<endl;
        int middle=int((1+k)/2);
        int f=1;
        for(int i=1;i<=middle;i++){
            if(s[i]!=s[k+1-i]){
                f=0;
                break;
            }
        }
        if(f){
            cout<<"Yes"<<endl;
        }else{
            cout<<"No"<<endl;
        }
        for(int i=k;i>=1;i--){
            cout<<s[i]-'0';//可能b的进制比较大,所以要-'0'输出 
            if(i!=1){
                cout<<" ";
            }
        }
        return 0;
    }
  • 相关阅读:
    Go 实现一个简单的TCP服务端
    将博客搬至CSDN
    My solution for Git Client Error: Permission denied (publickey)
    The Key to final data
    Design Pattern
    Difference between TCP and UDP
    Oracle SQL自带函数整理
    Java JDBC Batch
    Javascript Date 判断输入日期是否正确
    Javascript 数字保留2位小数
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/13270685.html
Copyright © 2011-2022 走看看