zoukankan      html  css  js  c++  java
  • poj 3253 Fence Repair (贪心,优先队列)

    Description

    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

    Input

    Line 1: One integer N, the number of planks 
    Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

    Output

    Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

    Sample Input

    3
    8
    5
    8

    Sample Output

    34

    Hint

    He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
    The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

    Source

     

    题意:

    有一位农夫要把一个木板钜成n块给定长度的小木板,每次锯都要收取一定费用,这个费用就是当前锯的这个木板的长度

    给定各个要求的小木板的长度,及小木板的个数n,求最小的费用;

    PS:

    3

    5 8 5为例:

    先从无限长的木板上锯下长度为 21 的木板,花费 21

    再从长度为21的木板上锯下长度为5的木板,花费5

    再从长度为16的木板上锯下长度为8的木板,花费8

    总花费 = 21+5+8 =34

    思路:

    要使总费用最小,那么每次只选取最小长度的两块木板相加,再把这些“和”累加到总费用中即可;

    #include <iostream>
    #include <cstring>
    #include <string>
    #include <algorithm>
    #include <queue>
    using namespace std;
    struct cmp
    {
        bool operator()(long long  x, long long y)
        {
            return x > y;
        }
    };
    priority_queue<long long ,vector<long long>,cmp>q;
    int main()
    {
        int n;
        int i;
        long long  x,y;
        long long s = 0;
        cin >> n;
        for (i = 1; i <= n; i++)
        {
            cin >> x;
            q.push(x);
        }
        while (q.size()>=2)
        {
            long long r;
            x = q.top(); q.pop();
            y = q.top(); q.pop();
            s = s + x + y;
            r = x + y;
            q.push(r);
        }
        cout << s << endl;
        return 0;
    }
  • 相关阅读:
    js加密解密 base64
    Server2003上部署Excel服务器
    SQL 2000和SQL 2005服务端口查看或修改
    IIS6.0的安装
    VSS 2005 配置(含录像)
    SQL2005开启远程连接功能
    SQL 2005 SP3在小内存计算机中安装(最佳方案)
    windows防火墙的使用
    Server2003上部署Excel服务器
    通过连接实例解读TCP/IP协议
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/13271264.html
Copyright © 2011-2022 走看看