zoukankan      html  css  js  c++  java
  • HDU 1078 FatMouse and Cheese

    FatMouse and Cheese

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 159   Accepted Submission(s) : 63

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

    FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

    Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

    Input

    There are several test cases. Each test case consists of

    a line containing two integers between 1 and 100: n and k
    n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
    The input ends with a pair of -1's.

    Output

    For each test case output in a line the single integer giving the number of blocks of cheese collected.

    Sample Input

    3 1
    1 2 5
    10 11 6
    12 12 7
    -1 -1
    

    Sample Output

    37

    //有趣的dp 和记忆化搜索
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <string>
    using namespace std;
    int a[105][105],dp[105][105];
    int b[4][2] = {1,0,-1,0,0,1,0,-1};  
    int n,k;
    int safe(int x,int y)
    {
        if(x<=0||y<=0||x>n||y>n) return 0;
        return 1;
    }
    int dfs(int x,int y)
    {
        int ans=0;
        int i,j,xx,yy;
        if(dp[x][y]==0)//!dp[x][y];
        {
            for(i=1;i<=k;i++)
            {
                for(j=0;j<4;j++)
                {
                    xx=x+b[j][0]*i;
                    yy=y+b[j][1]*i;
                    if(!safe(xx,yy)) continue;
                    if(a[xx][yy]>a[x][y])
                    {
                        ans = (ans>dfs(xx,yy)?ans:dfs(xx,yy));//挑出过去(以后那个格子之后跳的会是最大)的格子
                        //ans=max(ans,dfs(xx,yy));
                    }
                }
            }
            dp[x][y]=ans+a[x][y];
        }
        return dp[x][y];
    }
    
    
    
    int main()
    {
        while(cin>>n>>k)
        {
            if(n==-1&&k==-1) break;
            int i,j;
            for(i=1;i<=n;i++)
            {
                for(j=1;j<=n;j++)
                {
                    cin>>a[i][j];
                }
            }
            memset(dp,0,sizeof(dp));
            cout<<dfs(1,1)<<endl;
        }
        return 0;
    }
  • 相关阅读:
    用户和组管理
    权限管理
    文件查找
    文件管理 2
    文件管理
    2016多校训练3_1007(hdu5758 Explorer Bo)
    poj3334(Connected Gheeves)
    POJ1015-Jury Compromise
    使用python来访问Hadoop HDFS存储实现文件的操作
    微信H5自动播放音乐,视频解决方案
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/13271285.html
Copyright © 2011-2022 走看看