zoukankan      html  css  js  c++  java
  • HDU 1312 Red and Black

    Red and Black

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 23404    Accepted Submission(s): 14142


    Problem Description
    There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

    Write a program to count the number of black tiles which he can reach by repeating the moves described above.
     
    Input
    The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

    There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

    '.' - a black tile
    '#' - a red tile
    '@' - a man on a black tile(appears exactly once in a data set)
     
    Output
    For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
     
    Sample Input
    6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
     
    Sample Output
    45 59 6 13
    //暴力广搜
    #include <iostream>
    using namespace std;
    char map[25][25];
    int f[25][25];
    int dir[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
    int n,m,s,p;
    int safe (int a,int b)
    {
        if(a<=0||b<=0||a>n||b>m) return 0;
        else return 1;
    }
    void work(int x,int y)
    {
        int c;
        for(c=0;c<4;c++)
        {
            if(map[x+dir[c][0]][y+dir[c][1]]!='#'&&safe(x+dir[c][0],y+dir[c][1]))
                f[x+dir[c][0]][y+dir[c][1]]=p+1;
        }
        return;
    }
        
    int main()
    {
        int si,sj;
        while(cin>>m>>n)
        {
            if(n==0&&m==0) break;
            s=0;
            int i,j;
            for(i=1;i<=n;i++)
            {
                for(j=1;j<=m;j++)
                {
                    cin>>map[i][j];
                    if(map[i][j]=='@') {si=i;sj=j;}
                    f[i][j]=0;
                }
            }
            f[si][sj]=1;
            for(p=1;p<=500;p++)
            {
                for(i=1;i<=n;i++)
                {
                    for(j=1;j<=m;j++)
                    {
                        if(f[i][j]==p)
                        {
                            work(i,j);
    
                        }
    
                    }
                }
            }
            for(i=1;i<=n;i++)
            {
                for(j=1;j<=m;j++)
                {
                    if(f[i][j]>0) s++;
                    
                }
            }
            cout<<s<<endl;
        }
        return 0;
    }
  • 相关阅读:
    JavaScript面向对象之类的创建
    VSCode Debug模式下各图标 含义
    Visual Studio icon 含义
    Unity坐标系 左手坐标系 图
    Unity类继承关系 图
    Unity的SendMessage方法
    ONGUI->NGUI->UGUI (Unity UI史)
    Console.WriteLine 不会输出到unity控制台
    Chrome添加Unity本地文档引擎
    Unity "Build failed : Asset is marked as don't save " 解决方案
  • 原文地址:https://www.cnblogs.com/caiyishuai/p/8410959.html
Copyright © 2011-2022 走看看