zoukankan      html  css  js  c++  java
  • 拓扑排序 POJ2367Genealogical tree[topo-sort]

    ---恢复内容开始---

    Genealogical tree
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 4875   Accepted: 3236   Special Judge

    Description

    The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
    And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
    Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants. 

    Input

    The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

    Output

    The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

    Sample Input

    5
    0
    4 5 1 0
    1 0
    5 3 0
    3 0
    

    Sample Output

    2 4 5 3 1

    Source


    题意:给出孩子列表,求一个序列父亲在孩子前

    裸的拓扑排序
     vis-1 正在访问
     
    只有DAG才有
    //
    //  main.cpp
    //  poj2367
    //
    //  Created by Candy on 9/10/16.
    //  Copyright © 2016 Candy. All rights reserved.
    //
    
    #include <iostream>
    #include <cstdio>
    #include <algorithm>
    #include <cstring>
    using namespace std;
    const int N=105;
    int n,ch[N][N],t;
    int topo[N],vis[N];
    bool dfs(int u){
        vis[u]=-1;int cnt=ch[u][0];
        for(int i=1;i<=cnt;i++){
            int v=ch[u][i];
            if(vis[v]==-1) return false;
            if(!vis[v]&&!dfs(v)) return false;
        }
        vis[u]=1;topo[t--]=u;
        return true;
    }
    bool toposort(){
        t=n;
        for(int i=1;i<=n;i++) if(!vis[i])
            if(!dfs(i)) return false;
        return true;
    }
    int main(int argc, const char * argv[]) {
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            int a,cnt=0;
            while(true){
                scanf("%d",&a);if(a==0) break;
                ch[i][++cnt]=a;
            }
            ch[i][0]=cnt;
        }
        toposort();
        for(int i=1;i<=n;i++) printf("%d ",topo[i]);
        return 0;
    }
     
  • 相关阅读:
    oracle DBA 常用表和视图
    oracle 索引聚簇表的工作原理
    二进制手表
    二分查找
    二分查找
    排列硬币
    将每个元素替换为右侧最大元素
    搜索插入位置----二分查找
    合并两个有序数组
    在Nuxt遇到的坑
  • 原文地址:https://www.cnblogs.com/candy99/p/5861467.html
Copyright © 2011-2022 走看看