zoukankan      html  css  js  c++  java
  • POJ2425 A Chess Game[博弈论 SG函数]

    A Chess Game
    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 3917   Accepted: 1596

    Description

    Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again. 

    Do you want to challenge me? Just write your program to show your qualification!

    Input

    Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.

    Output

    There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.

    Sample Input

    4
    2 1 2
    0
    1 3
    0
    1 0
    2 0 2
    0
    
    4
    1 1
    1 2
    0
    0
    2 0 1
    2 1 1
    3 0 1 3
    0
    

    Sample Output

    WIN
    WIN
    WIN
    LOSE
    WIN
    

    Hint

    Huge input,scanf is recommended.

    Source

    PKU Monthly,CHEN Shixi(xreborner)

    裸SG函数搜索
    注意used不能共用一个
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<cmath>
    using namespace std;
    const int N=1e3+5,INF=1e9;
    int read(){
        char c=getchar();int x=0,f=1;
        while(c<'0'||c>'9'){if(c=='-')f=-1; c=getchar();}
        while(c>='0'&&c<='9'){x=x*10+c-'0'; c=getchar();}
        return x*f;
    }
    int n,s,v;
    struct edge{
        int v,w,ne;
    }e[N*N];
    int h[N],cnt=0;
    void ins(int u,int v){
        cnt++;
        e[cnt].v=v;e[cnt].ne=h[u];h[u]=cnt;
    }
    int sg[N];
    int dfs(int u){
        if(sg[u]!=-1) return sg[u];
        bool used[N];
        memset(used,0,sizeof(used));
        for(int i=h[u];i;i=e[i].ne) used[dfs(e[i].v)]=1;
        for(int i=0;;i++) if(!used[i]) {sg[u]=i;break;}
        return sg[u];
    }
    int main(){
        while(scanf("%d",&n)!=EOF){
            memset(sg,-1,sizeof(sg));
            memset(h,0,sizeof(h));
            cnt=0;
            for(int i=1;i<=n;i++){
                s=read();
                while(s--) ins(i,read()+1);
            }
            while((s=read())){
                int ans=0;
                for(int i=1;i<=s;i++) ans^=dfs(read()+1);
                if(ans) puts("WIN");
                else puts("LOSE"); 
            }
        }
    }
     
     
  • 相关阅读:
    [javaSE] 网络编程(浏览器客户端-自定义服务端)
    [javaSE] 网络编程(URLConnection)
    [javaSE] 网络编程(URL)
    [javaSE] IO流(FIle对象递归文件列表)
    tcping 与 telnet命令粗略使用
    让mysql监听ipv4
    shell脚本[] [[]] -n -z 的含义解析
    ansible的主机的默认配置部分
    MySQL备份与还原
    gunicorn 简介
  • 原文地址:https://www.cnblogs.com/candy99/p/6059764.html
Copyright © 2011-2022 走看看