zoukankan      html  css  js  c++  java
  • POJ2505 A multiplication game[博弈论]

    A multiplication game
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 6028   Accepted: 3013

    Description

    Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

    Input

    Each line of input contains one integer number n.

    Output

    For each line of input output one line either 
    Stan wins. 
    or 
    Ollie wins. 
    assuming that both of them play perfectly.

    Sample Input

    162
    17
    34012226

    Sample Output

    Stan wins.
    Ollie wins.
    Stan wins.
    

    Source


    手算一下吧
    0~9 stan
    10~9*2 ollie  //2是Stan,他要尽量阻止Ollie取到n;9是Ollie,他要尽量大来取到n
    19~9*2*9 stan
    以此类推
    可以直接用n不断/18
    注意double n
    #include<cstdio>
    double n;
    int main(){
        while(scanf("%lf",&n)!=EOF){
            while(n>18) n/=18;
            if(n<=9) puts("Stan wins.");
            else puts("Ollie wins.");
        }
    }
  • 相关阅读:
    video和audio
    H5-geolocation学习
    hammer.js学习
    echarts学习
    移动端手势识别
    SVG
    e.key && e.which && e.keyCode
    git中避免提交.DS_Store文件[转载]
    前端笔试题[1]
    Javascript实现格式化输出
  • 原文地址:https://www.cnblogs.com/candy99/p/6059819.html
Copyright © 2011-2022 走看看