zoukankan      html  css  js  c++  java
  • - > 网络流(草地排水)

    网络流(Dinic(模板))

    Drainage Ditches

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 16467    Accepted Submission(s): 7823


    Problem Description
    Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
    Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
    Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
     
    Input
    The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
     
    Output
    For each case, output a single integer, the maximum rate at which water may emptied from the pond. 
     
    Sample Input
    5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
     
    Sample Output
    50
     
    Source
     
    Recommend
    lwg
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<queue> 
    #define MAXN 300
    #define INF 9999999
    using namespace std;
    int N,M,map[MAXN][MAXN],a,b,f,maxflow,pre[MAXN];
    void flow(int start,int end){
    	while(1){
    		queue<int>q;
    		/*while(!q.empty())
    			q.pop();*/		
    		int minflow=INF;
    		q.push(1);
    		memset(pre,0,sizeof(pre));
    		while(!q.empty()){
    			int u=q.front();
    			q.pop();
    			if(u==end)	break; 
    			for(int i=1;i<=M;i++)
    				if(map[u][i]&&!pre[i]){
    					pre[i]=u;
    					q.push(i);
    				}
    		}
    		if(pre[end]==0)	break;
    		for(int i=end;i!=start;i=pre[i])
    			minflow=min(minflow,map[pre[i]][i]);
    		for(int i=end;i!=start;i=pre[i]){
    			map[pre[i]][i]-=minflow;
    			map[i][pre[i]]+=minflow;
    		}
    		maxflow+=minflow;
    	}
    }
    int main(){
    	cin>>N>>M;
    	for(int i=1;i<=N;i++){
    		cin>>a>>b>>f;
    		map[a][b]+=f;
    	}
    	maxflow;	//最大流 
    	flow(1,M);
    	cout<<maxflow;
    }
    

      

    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    php 图形用户界面GUI 开发
    centos实现两种秒级任务的简单方法
    rsync同步工具的配置与使用
    【转】网络字节序与主机字节序
    【转】Visual Studio 非常实用的调试技巧
    【原/转】【boost】智能指针使用规则以及介绍
    【转】一个非常常见但容易被忽略的c++问题——用IPML模式可以解决
    【转】Visual Studio项目相对路径的设置,实用
    【原】visual studio添加现有文件夹的方法
    【原】自定义UINavigationItem的两种方法以及相应的隐藏方法
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/6502908.html
Copyright © 2011-2022 走看看