zoukankan      html  css  js  c++  java
  • HDU 2767 Proving Equivalences

    Proving Equivalences

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 7454    Accepted Submission(s): 2591


    Problem Description
    Consider the following exercise, found in a generic linear algebra textbook.

    Let A be an n × n matrix. Prove that the following statements are equivalent:

    1. A is invertible.
    2. Ax = b has exactly one solution for every n × 1 matrix b.
    3. Ax = b is consistent for every n × 1 matrix b.
    4. Ax = 0 has only the trivial solution x = 0. 

    The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

    Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

    I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?
     
    Input
    On the first line one positive number: the number of testcases, at most 100. After that per testcase:

    * One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
    * m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.
     
    Output
    Per testcase:

    * One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.
     
    Sample Input
    2 4 0 3 2 1 2 1 3
     
    Sample Output
    4 2
     
    Source
     
    Recommend
    lcy   |   We have carefully selected several similar problems for you:  2768 2766 2769 2773 2772 
     
    #include<iostream>
    #include<cstdio> 
    #include<cstring>
    #include<algorithm>
    #define MAXN 100000+15
    using namespace std;
    int n,m,tot,tim,top,sumcol,ans,bns;
    int to[MAXN],from[MAXN],net[MAXN],x[MAXN],col[MAXN],into[MAXN],out[MAXN];
    int dfn[MAXN],low[MAXN],vis[MAXN],stack[MAXN],visstack[MAXN];
    void add(int u,int v){
        to[++tot]=v;x[tot]=u;net[tot]=from[u];from[u]=tot;
    }
    void tarjin(int now){
        low[now]=dfn[now]=++tim;
        stack[++top]=now;
        visstack[now]=1;
        vis[now]=1;
        for(int i=from[now];i;i=net[i])
            if(visstack[to[i]])
                low[now]=min(low[now],dfn[to[i]]);
            else if(!vis[to[i]]){
                tarjin(to[i]);
                low[now]=min(low[now],low[to[i]]);
            }
        if(dfn[now]==low[now]){
            sumcol++;
            col[now]=sumcol;
            while(stack[top]!=now){
                col[stack[top]]=sumcol;
                visstack[stack[top]]=0;
                top--;
            }
            visstack[now]=0;
            top--;
        } 
    }
    int T;
    int main(){
        cin>>T;
        while(T--){
            top=0;tot=0;sumcol=0;tim=0;
            ans=0;bns=0;
            memset(to,0,sizeof(to));
            memset(low,0,sizeof(low));
            memset(dfn,0,sizeof(dfn));
            memset(vis,0,sizeof(vis));
            memset(col,0,sizeof(col));
            memset(net,0,sizeof(net));
            memset(out,0,sizeof(out));
            memset(into,0,sizeof(into));
            memset(from,0,sizeof(from));
            memset(stack,0,sizeof(stack));
            memset(visstack,0,sizeof(visstack));
            cin>>n>>m;
            for(int i=1;i<=m;i++){
                int a,b;
                cin>>a>>b;
                add(a,b);
            }
            for(int i=1;i<=n;i++)
                if(!vis[i])    tarjin(i);
            if(sumcol==1){
                cout<<"0"<<endl;
                continue;
            }
            for(int i=1;i<=tot;i++)
                if(col[to[i]]!=col[x[i]]){
                    into[col[to[i]]]++;
                    out[col[x[i]]]++;
                }
            for(int i=1;i<=sumcol;i++){
                if(into[i]==0)    ans++;
                if(out[i]==0)    bns++;
            }
            cout<<max(ans,bns)<<endl;
        }
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    python爬取代理IP地址
    神经网络训练的过程
    机器学习中用到的数学概念
    Navicat连接Mysql错误代码1251
    mysql安装
    mysql运行找不到MSVCP140.dll
    tomcat 日志乱码
    扁平化 Flat
    常见的WEB安全及防护
    CentOS ceph 集群搭建(单节点)
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/7400221.html
Copyright © 2011-2022 走看看