zoukankan      html  css  js  c++  java
  • cogs 315. [POJ3255] 地砖RoadBlocks

    315. [POJ3255] 地砖RoadBlocks

    ★★★   输入文件:block.in   输出文件:block.out   简单对比
    时间限制:1 s   内存限制:128 MB

    Description

    Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

    The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

    The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

     

    贝茜搬到了一个小农场去住,但她很享受偶尔回去看看她的一个好朋友。贝茜很喜欢沿途的风景,因此她希望路上走的尽可能慢一些。于是她决定走次短路而不是最短路。

    城郊包含R(1<=R<=100,000)条双向的路,它们分别连接了N(1<=N<=5000)个十字路口(节点),为了方便我们把它们标记为1..N。贝茜从1号节点出发,她的好朋友(目的地)在N号节点。

    次短路和最短路可以部分重合,次短路也有可能经过同一条路或同一个节点多次。次短路是长于最短路的路中最短的那一条。当有多个最短路存在时,次短路是其他所有路中最短的那条。

     

    Input

    Line 1: Two space-separated integers: N and R 

    Lines 2..R+1: Each line contains three space-separated integers: AB, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)

     

    输入:

    第1行:两个被空格分开的整数N和R

    第2..R+1行:每行包括三个由空格分开的整数A,B和D组成。用来描述连接节点A和节点B之间路径的长度是D(1<=D<=5000)。

     

    Output

    Line 1: The length of the second shortest path between node 1 and node N

     

    输出:

    第一行:一个整数表示从节点1到节点N之间次短路的长度。

     

    Sample Input

    4 4
    1 2 100
    2 4 200
    2 3 250
    3 4 100

    Sample Output

    450

    Hint

    Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

     

    提示:

    样例中由两条从节点1到节点N的路分别是1->2->4(len=100+200=300(最短路))和1->2->3->4(100+250+100=450(次短路))。

    译byKZFFFFFFFF

     思路:次短路板子

    #include<iostream>
    #include<queue>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #define INF 0x3f3f3f3f
    #define MAXN 400000
    using namespace std;
    struct nond{
        int g,f,to;
        bool operator<(const nond &r) const {
            if(r.f==f)    return r.g<g;
            else return r.f<f;
        }
    }tmp,opt;
    int n,m,p,s,t,cnt,tot,tot1,tot2;
    int dis[MAXN],vis[MAXN],dis2[MAXN],vis2[MAXN];
    int to[MAXN],net[MAXN],cap[MAXN],head[MAXN];
    int to1[MAXN],net1[MAXN],cap1[MAXN],head1[MAXN];
    void add(int u,int v,int w){
        to[++tot]=v;net[tot]=head[u];cap[tot]=w;head[u]=tot;
        to[++tot]=u;net[tot]=head[v];cap[tot]=w;head[v]=tot;
        to1[++tot1]=v;net1[tot1]=head1[u];cap1[tot1]=w;head1[u]=tot1;
        to1[++tot1]=u;net1[tot1]=head1[v];cap1[tot1]=w;head1[v]=tot1;
    }
    void spfa(int s){
        queue<int>que1;
        for(int i=0;i<=n;i++)    dis[i]=INF;
        que1.push(s);
        vis[s]=1;dis[s]=0;
        while(!que1.empty()){
            int now=que1.front();
            que1.pop();
            vis[now]=0;
            for(int i=head1[now];i;i=net1[i])
                if(dis[to1[i]]>dis[now]+cap1[i]){
                    dis[to1[i]]=dis[now]+cap1[i];
                    if(!vis[to1[i]]){
                        vis[to1[i]]=1;
                        que1.push(to1[i]);
                    }
                }
        }
    }
    int Astar(int kk){
        priority_queue<nond>que;
        if(s==t)    kk++;
        if(dis[s]==INF)    return -1;
        tmp.g=0;
        tmp.to=s;
        tmp.f=dis[s];
    tmp.vis[s]=1; que.push(tmp);
    while(!que.empty()){ tmp=que.top(); que.pop(); if(tmp.to==t) cnt++; if(cnt==kk) return tmp.g; for(int i=head[tmp.to];i;i=net[i]){ opt.to=to[i]; opt.g=tmp.g+cap[i]; opt.f=opt.g+dis[to[i]]; que.push(opt); } } return -1; } int main(){ freopen("block.in","r",stdin); freopen("block.out","w",stdout); scanf("%d%d",&n,&m); for(int i=1;i<=m;i++){ int a,b,c; scanf("%d%d%d",&a,&b,&c); add(a,b,c); } s=1;t=n; spfa(t); for(int i=1;i<=n;i++){ cnt=0; int ans=Astar(i); if(ans!=dis[s]){ printf("%d",ans); return 0; } } }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    Python协程
    Python3常用标准库
    温故而知新--day3
    温故而知新--day2
    解决 WPF 绑定集合后数据变动界面却不更新的问题
    WPF 消息框 TextBox 绑定新数据时让光标和滚动条跳到最下面
    C# 枚举转列表
    真・WPF 按钮拖动和调整大小
    使用 GB28181.Solution + ZLMediaKit + MediaServerUI 进行摄像头推流和播放
    将 .NET Framework 项目转换为 .NET Standard 项目
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/7411670.html
Copyright © 2011-2022 走看看