zoukankan      html  css  js  c++  java
  • poj 3628 Bookshelf 2

                                                                                                                                         Bookshelf 2
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 10981   Accepted: 4860

    Description

    Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

    FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

    To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

    Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

    Input

    * Line 1: Two space-separated integers: N and B
    * Lines 2..N+1: Line i+1 contains a single integer: Hi

    Output

    * Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

    Sample Input

    5 16
    3
    1
    3
    5
    6

    Sample Output

    1

    Source

    思路:如果正向去计算大于d的最小值,贪心是很好实现的,但是DP想起来有点困难,所以就换了个思路。设sum为所有奶牛的高度和,则sum>=B,那么我们就可以设有一个容量为sum-B的背包,要让里面所有牛的高度尽量大,那余下的就是我们要求的值了,这就转换成简单的01背包了。
    吐槽:不知道从哪位dalao博客里仿佛见到过“正难则反”(xxy是我o(*^▽^*)┛是我✿✿ヽ(°▽°)ノ✿),这个题目就让我想起了它。
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    int n,b,W,sum,num[25],f[2000000];
    int main(){
        scanf("%d%d",&n,&b);
        for(int i=1;i<=n;i++){
            scanf("%d",&num[i]);
            sum+=num[i];
        }
        W=sum-b;
        for(int i=1;i<=n;i++)
            for(int j=W;j>=num[i];j--)
                f[j]=max(f[j],f[j-num[i]]+num[i]);
        printf("%d",sum-f[W]-b);
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    试图加载格式不正确的程序。 (异常来自 HRESULT:0x8007000B)
    git 撤销刚提交的 commint
    At least one cache should be provided per cache operation.
    @Primary注解
    怎么把sql server数据导入mysql本地数据库?
    应用程序已预编译,因此不允许使用目录“/App_Code/”
    SpringBoot学习笔记15——Dozer的使用用来两个对象之间属性转换的工具
    Invalid packaging for parent POM (pom.xml), must be "pom" but is "jar" @ pom.xml
    浏览器调试console的多种用法
    bug本天成,妙手偶得之。
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/7434530.html
Copyright © 2011-2022 走看看