zoukankan      html  css  js  c++  java
  • 洛谷 P2896 [USACO08FEB]一起吃饭Eating Together

    题目描述

    The cows are so very silly about their dinner partners. They have organized themselves into three groups (conveniently numbered 1, 2, and 3) that insist upon dining together. The trouble starts when they line up at the barn to enter the feeding area.

    Each cow i carries with her a small card upon which is engraved Di (1 ≤ Di ≤ 3) indicating her dining group membership. The entire set of N (1 ≤ N ≤ 30,000) cows has lined up for dinner but it's easy for anyone to see that they are not grouped by their dinner-partner cards.

    FJ's job is not so difficult. He just walks down the line of cows changing their dinner partner assignment by marking out the old number and writing in a new one. By doing so, he creates groups of cows like 111222333 or 333222111 where the cows' dining groups are sorted in either ascending or descending order by their dinner cards.

    FJ is just as lazy as the next fellow. He's curious: what is the absolute mminimum number of cards he must change to create a proper grouping of dining partners? He must only change card numbers and must not rearrange the cows standing in line.

    每次可以改变一个数字,要求使给定的数列变成单调递增或递减,求最小操作数

    输入输出格式

    输入格式:

     

    • Line 1: A single integer: N

    • Lines 2..N+1: Line i describes the i-th cow's current dining group with a single integer: Di

     

    输出格式:

     

    • Line 1: A single integer representing the minimum number of changes that must be made so that the final sequence of cows is sorted in either ascending or descending order

     

    输入输出样例

    输入样例#1:
    5
    1
    3
    2
    1
    1
    
    输出样例#1:
    1
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int n,a[30010],f[30010][4][3];
    int main(){
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(int i=1;i<=n;i++){
            f[i][1][0]=f[i-1][1][0]+(a[i]!=1);
            f[i][2][0]=min(f[i-1][1][0],f[i-1][2][0])+(a[i]!=2);
            f[i][3][0]=min(f[i-1][1][0],min(f[i-1][2][0],f[i-1][3][0]))+(a[i]!=3);
            f[i][1][1]=min(f[i-1][1][1],min(f[i-1][2][1],f[i-1][3][1]))+(a[i]!=1);
            f[i][2][1]=min(f[i-1][3][1],f[i-1][2][1])+(a[i]!=2);
            f[i][3][1]=f[i-1][3][1]+(a[i]!=3);
        }
        cout<<min(f[n][1][0],min(f[n][2][0],min(f[n][3][0],min(f[n][1][1],min(f[n][2][1],f[n][3][1])))));
    }
     
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    Application Cache
    log4net--帮助程序员将日志信息输出到各种目标(控制台、文件、数据库等)的工具
    configsections規範配置信息
    Winform後台如何動態修改App.config文件里的內容
    運行程式時提示丟失api-ms-win-crt-runtime-l1-1-0.dll
    Extjs4对Model定义相关的校验内容
    liferay 集成ldap
    liferay和cas系统集成
    DOM获得所有元素的节点
    核心Element对象
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/7435882.html
Copyright © 2011-2022 走看看