zoukankan      html  css  js  c++  java
  • 洛谷 P2949 [USACO09OPEN]工作调度Work Scheduling

    题目描述

    Farmer John has so very many jobs to do! In order to run the farm efficiently, he must make money on the jobs he does, each one of which takes just one time unit.

    His work day starts at time 0 and has 1,000,000,000 time units (!). He currently can choose from any of N (1 <= N <= 100,000) jobs

    conveniently numbered 1..N for work to do. It is possible but

    extremely unlikely that he has time for all N jobs since he can only work on one job during any time unit and the deadlines tend to fall so that he can not perform all the tasks.

    Job i has deadline D_i (1 <= D_i <= 1,000,000,000). If he finishes job i by then, he makes a profit of P_i (1 <= P_i <= 1,000,000,000).

    What is the maximum total profit that FJ can earn from a given list of jobs and deadlines? The answer might not fit into a 32-bit integer.

    约翰有太多的工作要做。为了让农场高效运转,他必须靠他的工作赚钱,每项工作花一个单位时间。 他的工作日从0时刻开始,有1^8个单位时间。在任一时刻,他都可以选择编号1~N的N(1 <= N <= 10^6)项工作中的任意一项工作来完成。 因为他在每个单位时间里只能做一个工作,而每项工作又有一个截止日期,所以他很难有时间完成所有N个工作,虽然还是有可能。 对于第i个工作,有一个截止时间D_i(1 <= D_i <= 10^9),如果他可以完成这个工作,那么他可以获利P_i( 1<=P_i<=10^9 ). 在给定的工作利润和截止时间下,约翰能够获得的利润最大为多少.

    输入输出格式

    输入格式:

     

    • Line 1: A single integer: N

    • Lines 2..N+1: Line i+1 contains two space-separated integers: D_i and P_i

     

    输出格式:

     

    • Line 1: A single number on a line by itself that is the maximum possible profit FJ can earn.

     

    输入输出样例

    输入样例#1:
    3 
    2 10 
    1 5 
    1 7 
    
    输出样例#1:
    17 
    

    说明

    Complete job 3 (1,7) at time 1 and complete job 1 (2,10) at time 2 to maximize the earnings (7 + 10 -> 17).

    思路:用一个优先对列进行贪心。

    错因:优先队列的优先级是先大后小,我以为是先小后大。

    #include<queue>
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int n;
    long long ans,time;
    struct nond{
        long long end,val;
    }v[1000001];
    priority_queue<long long,vector<long long>,greater<long long> >que;
    int cmp(nond a,nond b){
        return a.end<b.end;
    }
    int main(){
        cin>>n;
        for(int i=1;i<=n;i++)
            cin>>v[i].end>>v[i].val;
        sort(v+1,v+1+n,cmp);
        for(int i=1;i<=n;i++){
            if(time<v[i].end){
                time++;
                ans+=v[i].val;
                que.push(v[i].val);
            }
            else if(time==v[i].end&&que.top()<v[i].val){
                ans-=que.top();
                ans+=v[i].val;
                que.pop();
                que.push(v[i].val);
            }
        }
        cout<<ans;
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    线程私有关键字配合static使用
    对定义局部变量位置的思考
    获取文件的md5值
    JNI接口的整理
    数兔子问题
    使用XML布局文件和java代码混合控制UI界面
    应用程序类型
    android组成
    封装
    接口
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/7562744.html
Copyright © 2011-2022 走看看