zoukankan      html  css  js  c++  java
  • 洛谷 P3419 [POI2005]SAM-Toy Cars

    题目描述

    Johnny is a little boy - he is only three years old and enjoys playing with toy cars very much. Johnny has nn different cars. They are kept on a shelf so high, that Johnny cannot reach it by himself. As there is little space in his room, at no moment may there be more than kk toy cars on the floor.

    Johnny plays with one of the cars on the floor. Johnny's mother remains in the room with her son all the time. When Johnny wants to play with another car that is on the floor, he reaches it by himself. But when the toy is on the shelf, his mummy has to hand it to him. When she gives Johnny one car, she can at the same time pick any car from the floor and put it back on the shelf (so that there remains sufficient space on the floor).

    The mother knows her child very well and therefore can predict perfectly which cars Johnny will want to play with. Having this knowledge, she wants to minimize the number of times she has to hand Johnny a toy from the shelf. Keeping that in mind, she has to put the toys off on the shelf extremely thoughtfully.

    TaskWrite a programme that:

    reads from the standard input the sequence of toy cars in order in which Johnny will want to play with them,calculates the minimal number of times the mother has to pick cars from the shelf,writes the result to the standard output.

    Jasio 是一个三岁的小男孩,他最喜欢玩玩具了,他有n 个不同的玩具,它们都被放在了很高的架子上所以Jasio 拿不到它们. 为了让他的房间有足够的空间,在任何时刻地板上都不会有超过k 个玩具. Jasio 在地板上玩玩具. Jasio'的妈妈则在房间里陪他的儿子. 当Jasio 想玩地板上的其他玩具时,他会自己去拿,如果他想玩的玩具在架子上,他的妈妈则会帮他去拿,当她拿玩具的时候,顺便也会将一个地板上的玩具放上架子使得地板上有足够的空间. 他的妈妈很清楚自己的孩子所以他能够预料到Jasio 想玩些什么玩具. 所以她想尽量的使自己去架子上拿玩具的次数尽量的少,应该怎么安排放玩具的顺序呢?

    输入输出格式

    输入格式:

     

    In the first line of the standard input there are three integers: nn,kk,pp (1le kle nle 100 0001kn100 000, 1le ple 500 0001p500 000), separated by single spaces. These denote respectively: the total number of cars, the number of cars that can remain on the floor at once and the length of the sequence of cars which Johnny will want to play with. Each of the following pp lines contains one integer. These integers are the numbers of cars Johnny will want to play with (the cars are numbered from 11 to nn).

     

    输出格式:

     

    In the first and only line of the standard output one integer should be written - the minimal number of times his mother has to pick a car from the shelf.

     

    输入输出样例

    输入样例#1:
    3 2 7
    1
    2
    3
    1
    3
    1
    2
    输出样例#1:
    4
    思路:经典的贪心
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define MAXN 500001
    using namespace std;
    struct nond{
        int net,id;
    }heap[MAXN];
    int ans;
    int vis[MAXN];
    int n,k,m,size;
    int a[MAXN],net[MAXN],last[MAXN];
    void add(int net,int x){
        size++;
        int place=size,parent=size>>1;
        while(parent>=1&&heap[parent].net<net){
            heap[place]=heap[parent];
            place=parent;
            parent>>=1;
        }
        heap[place].net=net;
        heap[place].id=x;
    }
    void deletee(){
        nond now=heap[size--];
        int place=1,child=2;
        while(child<size){
            if(child<size&&heap[child].net<heap[child+1].net)
                child++;
            if(heap[child].net>now.net){
                heap[place]=heap[child];
                place=child;
                child<<=1;
            }
            else break;
        }
        heap[place]=now;
        return ;
    }
    int main(){
        scanf("%d%d%d",&n,&k,&m);
        for(int i=1;i<=m;i++)
            scanf("%d",&a[i]);
        for(int i=1;i<=n;i++)    last[i]=MAXN+1;
        for(int i=m;i>=1;i--){
            net[i]=last[a[i]];
            last[a[i]]=i;
        }    
        int cnt=0;
        for(int i=1;i<=m;i++){
            if(vis[a[i]]){
                add(net[i],a[i]);
                continue;
            }
            if(cnt<k){
                ans++;
                cnt++;
                add(net[i],a[i]);
                vis[a[i]]=1;
            }
            else{
                while(vis[heap[1].id]==0)    deletee();
                vis[heap[1].id]=0;
                deletee();
                ans++;
                vis[a[i]]=1;
                add(net[i],a[i]);
            }
        }
        cout<<ans;
    }
     
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    写给实习生的第一天
    写给实习生的第一天
    写给实习生的第一天
    老师不能把你怎样,但外面的世界可以!
    老师不能把你怎样,但外面的世界可以!
    adjA=(detA)A-1
    如果它仅对输入0才得到输出0
    isotropic trace
    detAB=detAdetB
    解释 纯量矩阵
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/7654754.html
Copyright © 2011-2022 走看看