zoukankan      html  css  js  c++  java
  • 洛谷 P3130 [USACO15DEC]计数haybalesCounting Haybales

    题目描述

    Farmer John is trying to hire contractors to help rearrange his farm, but so far all of them have quit when they saw the complicated sequence of instructions FJ wanted them to follow. Left to complete the project by himself, he realizes that indeed, he has made the project perhaps more complicated than necessary. Please help him follow his instructions to complete the farm upgrade.

    FJ's farm consists of NN fields in a row, conveniently numbered 1 ldots N1N. In each field there can be any number of haybales. Farmer John's instructions contain three types of entries:

    1) Given a contiguous interval of fields, add a new haybale to each field.

    2) Given a contiguous interval of fields, determine the minimum number of haybales in a field within that interval.

    3) Given a contiguous interval of fields, count the total number of haybales inside that interval.

    FJ像雇佣几个人在他的农场里帮忙,他需要进行很多种操作,请你帮他搞定。

    FJ的农场有N块田地排长一行,编号是从1到N的。每一块田地都有很多草包。FJ要进行下面几种操作:

    1)给定一段连续的田地,给每一个田地都增加一些新的草包。

    2)给定一段连续的田地,找出草包最少的田地有多少草包。

    3)给定一段连续的田地,统计一共有多少草包。

    输入输出格式

    输入格式:

     

    The first line contains two positive integers, NN (1 leq N leq 200,0001N200,000) and

    QQ (1 leq Q leq 100,0001Q100,000).

    The next line contains NN nonnegative integers, each at most 100,000,

    indicating how many haybales are initially in each field.

    Each of the next QQ lines contains a single uppercase letter, either M, P or S,

    followed by either two positive integers AA and BB (1 leq A leq B leq N1ABN),

    or three positive integers AA, BB, and CC (1 leq A leq B leq N1ABN;

    1 leq C leq 100,0001C100,000). There will be three positive integers if and only if

    the uppercase letter is P.

    If the letter is M, print the minimum number of haybales in the interval of fields

    from A ldots BAB.

    If the letter is P, put CC new haybales in each field in the interval of fields

    from A ldots BAB.

    If the letter is S, print the total number of haybales found within interval of

    fields from A ldots BAB.

     

    输出格式:

     

    A line in the output should appear in response to every 'M' or 'S' entry in FJ's

    instructions.

     

    输入输出样例

    输入样例#1: 复制
    4 5
    3 1 2 4
    M 3 4
    S 1 3
    P 2 3 1
    M 3 4
    S 1 3
    输出样例#1: 复制
    2
    6
    3
    8
    思路:裸的线段树,区间修改+区间查询。标签写着并差集,不知道并差集可不可做。
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define MAXN 200010
    using namespace std;
    int n,m;
    struct nond{
        int l,r;
        long long min,sum,flag;
    }tree[MAXN*4];
    void up(int now){
        tree[now].sum=tree[now*2].sum+tree[now*2+1].sum;
        tree[now].min=min(tree[now*2].min,tree[now*2+1].min);
    }
    void build(int now,int l,int r){
        tree[now].l=l;
        tree[now].r=r;
        if(tree[now].l==tree[now].r){
            scanf("%lld",&tree[now].sum);
            tree[now].min=tree[now].sum;
            return ;
        }
        int mid=(tree[now].l+tree[now].r)/2;
        build(now*2,l,mid);
        build(now*2+1,mid+1,r);
        up(now);
    }
    void down(int now){
        tree[now*2].flag+=tree[now].flag;
        tree[now*2+1].flag+=tree[now].flag;
        tree[now*2].min+=tree[now].flag;
        tree[now*2+1].min+=tree[now].flag;
        tree[now*2].sum+=(tree[now*2].r-tree[now*2].l+1)*tree[now].flag;
        tree[now*2+1].sum+=(tree[now*2+1].r-tree[now*2+1].l+1)*tree[now].flag;
        tree[now].flag=0;
    }
    void change(int now,int l,int r,long long opt){
        if(tree[now].l==l&&tree[now].r==r){
            tree[now].min+=opt;
            tree[now].flag+=opt;
            tree[now].sum+=(tree[now].r-tree[now].l+1)*opt;
            return ;
        }
        if(tree[now].flag)    down(now);
        int mid=(tree[now].l+tree[now].r)/2;
        if(r<=mid)    change(now*2,l,r,opt);
        else if(l>mid)    change(now*2+1,l,r,opt);
        else{
            change(now*2,l,mid,opt);
            change(now*2+1,mid+1,r,opt);
        }
        up(now);
    }
    long long query(int now,int l,int r,int opt){
        if(tree[now].l==l&&tree[now].r==r){
            if(opt==1)    return tree[now].sum;
            else return tree[now].min;
        }
        if(tree[now].flag)    down(now);
        int mid=(tree[now].l+tree[now].r)/2;
        if(r<=mid)    return query(now*2,l,r,opt);
        else if(l>mid)    return query(now*2+1,l,r,opt);
        else{
            if(opt==1)    return query(now*2,l,mid,opt)+query(now*2+1,mid+1,r,opt);
            else return min(query(now*2,l,mid,opt),query(now*2+1,mid+1,r,opt));
        }
    }
    int main(){
        scanf("%d%d",&n,&m);
        build(1,1,n);
        for(int i=1;i<=m;i++){
            char s[10];int x,y,z;
            scanf("%s%d%d",s,&x,&y);
            if(s[0]=='S')    cout<<query(1,x,y,1)<<endl;
            if(s[0]=='M')    cout<<query(1,x,y,0)<<endl;
            if(s[0]=='P'){
                scanf("%lld",&z);
                change(1,x,y,z);
            }
        }
    }
    
    /*
    4 5
    3 1 2 4
    M 3 4
    S 1 3
    P 2 3 1
    M 3 4
    S 1 3
    */
     
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    echarts 变量a、b、c、d的含义
    JS实现字符点点loading效果
    ES6的异步 async promise
    ES6中Promise封装ajax的写法
    ES6 set数据结构举例
    notepad++ 正则替换 字符串开始 字符串结束
    php去除bom
    jquery-ui Datepicker 创建 销毁
    Vue-cli3 WARNING in asset size limit: The following asset(s) exceed the recommended size limit (244 KiB)
    XManager product key
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/7711820.html
Copyright © 2011-2022 走看看