zoukankan      html  css  js  c++  java
  • 洛谷 P2879 [USACO07JAN]区间统计Tallest Cow

    题目描述

    FJ's N (1 ≤ N ≤ 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.

    FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form "cow 17 sees cow 34". This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.

    For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

    给出牛的可能最高身高,然后输入m组数据 a b,代表a,b可以相望,最后求所有牛的可能最高身高输出

    输入输出格式

    输入格式:

     

    Line 1: Four space-separated integers: N, I, H and R

    Lines 2..R+1: Two distinct space-separated integers A and B (1 ≤ A, B ≤ N), indicating that cow A can see cow B.

     

    输出格式:

     

    Lines 1..N: Line i contains the maximum possible height of cow i.

     

    输入输出样例

    输入样例#1: 复制
    9 3 5 5
    1 3
    5 3
    4 3
    3 7
    9 8
    输出样例#1: 复制
    5
    4
    5
    3
    4
    4
    5
    5
    5
    思路:贪心。首先全部赋值为最大值,然后进行贪心。
    去重后,把区间l,r之间的值均减去一。
    或者先判断区间l,r之间的最大值,如果比两个端点都就不进行修改,防止修改。
    不去重
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define MAXN 10010
    using namespace std;
    int n,m,pos,maxh;
    int h[MAXN];
    int main(){
        scanf("%d%d%d%d",&n,&pos,&maxh,&m);
        for(int i=1;i<=n;i++)    h[i]=maxh;
        for(int i=1;i<=m;i++){
            int l,r;
            scanf("%d%d",&l,&r);
            if(l>r)    swap(l,r);
            if(abs(l-r)!=1){
                int maxn=-1;
                for(int j=l+1;j<r;j++)
                    maxn=max(maxn,h[j]);
                if(maxn>=min(h[l],h[r]))
                    for(int j=l+1;j<r;j++)
                        h[j]-=1;
            }
        }
        for(int i=1;i<=n;i++)
            cout<<h[i]<<endl;
    }
    去重
    #include<set> #include<cstdio> #include<cstring> #include<iostream> #include<algorithm> #define MAXN 10010 using namespace std; set<int>se[MAXN]; int n,m,pos,maxh; int h[MAXN]; int main(){ scanf("%d%d%d%d",&n,&pos,&maxh,&m); for(int i=1;i<=n;i++) h[i]=maxh; for(int i=1;i<=m;i++){ int l,r; scanf("%d%d",&l,&r); if(l>r) swap(l,r); if(se[l].find(r)!=se[l].end()) continue; se[l].insert(r); if(abs(l-r)!=1) for(int j=l+1;j<r;j++) h[j]-=1; } for(int i=1;i<=n;i++) cout<<h[i]<<endl; }
     
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    Cocos2d-JS中的Sprite精灵类
    Cocos2d-JS中的精灵菜单和图片菜单
    Cocos2d-JS中的文本菜单
    SpringMVC01
    xml文件
    MyEclipse保存文件时 自动格式化代码! 不包括文档注释
    MyEclipse修改servlet模版
    java05 选择结构
    ssh注解开发
    使用socket实现聊天功能
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/7791563.html
Copyright © 2011-2022 走看看