zoukankan      html  css  js  c++  java
  • 洛谷 P2616 [USACO10JAN]购买饲料II Buying Feed, II

    题目描述

    Farmer John needs to travel to town to pick up K (1 <= K <= 100) pounds of feed. Driving D miles with K pounds of feed in his truck costs D*K cents.

    The county feed lot has N (1 <= N <= 100) stores (conveniently numbered 1..N) that sell feed. Each store is located on a segment of the X axis whose length is E (1 <= E <= 350). Store i is at location X_i (0 < X_i < E) on the number line and can sell FJ as much as F_i (1 <= F_i <= 100) pounds of feed at a cost of C_i (1 <= C_i <= 1,000,000) cents per pound. Amazingly, a given point on the X axis might have more than one store.

    FJ starts at location 0 on this number line and can drive only in the positive direction, ultimately arriving at location E, with at least K pounds of feed. He can stop at any of the feed stores along the way and buy any amount of feed up to the the store's limit.

    What is the minimum amount FJ has to pay to buy and transport the K pounds of feed? FJ knows there is a solution.

    Consider a sample where FJ needs two pounds of feed from three stores (locations: 1, 3, and 4) on a number line whose range is 0..5:

    0   1   2   3   4   5 
    +---|---+---|---|---+ 
    1       1   1      Available pounds of feed 
    1       2   2      Cents per pound 

    It is best for FJ to buy one pound of feed from both the second and third stores. He must pay two cents to buy each pound of feed for a total cost of 4. When FJ travels from 3 to 4 he is moving 1 unit of length and he has 1 pound of feed so he must pay 1*1 = 1 cents.

    When FJ travels from 4 to 5 he is moving one unit and he has 2 pounds of feed so he must pay 1*2 = 2 cents.

    The total cost is 4+1+2 = 7 cents.

    FJ开车去买K份食物,如果他的车上有X份食物。每走一里就花费X元。 FJ的城市是一条线,总共E里路,有E+1个地方,标号0~E。 FJ从0开始走,到E结束(不能往回走),要买K份食物。 城里有N个商店,每个商店的位置是X_i(一个点上可能有多个商店),有F_i份食物,每份C_i元。 问到达E并买K份食物的最小花费

    输入输出格式

    输入格式:

     

     

    输出格式:

     

     

    输入输出样例

    输入样例#1: 复制
    2 5 3
    3 1 2
    4 1 2
    1 1 1
    输出样例#1: 复制
    7

    说明

     思路:可以转化为01背包求解,也可以排序后贪心。

    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int k,e,n,tot;
    int f[10010];
    int cost[10010];
    int x[110],y[110],z[110];
    int main(){
        scanf("%d%d%d",&k,&e,&n);
        for(int i=1;i<=n;i++)    scanf("%d%d%d",&x[i],&y[i],&z[i]);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=y[i];j++)
                cost[++tot]=z[i]+e-x[i];
        memset(f,0x7f,sizeof(f));
        f[0]=0;
        for(int i=1;i<=tot;i++)
            for(int j=k;j>=1;j--)
                f[j]=min(f[j],f[j-1]+cost[i]);
        cout<<f[k];
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    程序员面试金典-面试题 08.12. 八皇后
    程序员面试金典-面试题 08.11. 硬币
    程序员面试金典-面试题 08.10. 颜色填充
    程序员面试金典-面试题 08.09. 括号
    程序员面试金典-面试题 08.08. 有重复字符串的排列组合
    程序员面试金典-面试题 08.07. 无重复字符串的排列组合
    程序员面试金典-面试题 08.06. 汉诺塔问题
    python学习笔记-27 使用@property
    python学习笔记-25 实例属性和类属性
    python学习笔记-26 使用__slots__
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/7887252.html
Copyright © 2011-2022 走看看