zoukankan      html  css  js  c++  java
  • 洛谷 P1535 游荡的奶牛

    题目描述

    Searching for the very best grass, the cows are travelling about the pasture which is represented as a grid with N rows and M columns (2 <= N <= 100; 2 <= M <= 100). Keen observer Farmer John has recorded Bessie's position as (R1, C1) at a certain time and then as (R2, C2) exactly T (0 < T <= 15) seconds later. He's not sure if she passed through (R2, C2) before T seconds, but he knows she is there at time T.

    FJ wants a program that uses this information to calculate an integer S that is the number of ways a cow can go from (R1, C1) to (R2, C2) exactly in T seconds. Every second, a cow can travel from any position to a vertically or horizontally neighboring position in the pasture each second (no resting for the cows). Of course, the pasture has trees through which no cow can travel.

    Given a map with '.'s for open pasture space and '*' for trees, calculate the number of possible ways to travel from (R1, C1) to (R2, C2) in T seconds.

    奶牛们在被划分成N行M列(2 <= N <= 100; 2 <= M <= 100)的草地上游走, 试图找到整块草地中最美味的牧草。Farmer John在某个时刻看见贝茜在位置 (R1, C1),恰好T (0 < T <= 15)秒后,FJ又在位置(R2, C2)与贝茜撞了正着。 FJ并不知道在这T秒内贝茜是否曾经到过(R2, C2),他能确定的只是,现在贝茜 在那里。 设S为奶牛在T秒内从(R1, C1)走到(R2, C2)所能选择的路径总数,FJ希望有 一个程序来帮他计算这个值。每一秒内,奶牛会水平或垂直地移动1单位距离( 奶牛总是在移动,不会在某秒内停在它上一秒所在的点)。草地上的某些地方有 树,自然,奶牛不能走到树所在的位置,也不会走出草地。 现在你拿到了一张整块草地的地形图,其中'.'表示平坦的草地,'*'表示 挡路的树。你的任务是计算出,一头在T秒内从(R1, C1)移动到(R2, C2)的奶牛 可能经过的路径有哪些。

    输入输出格式

    输入格式:

     

    第1 行: 3 个用空格隔开的整数:N,M,T 。 第2..N+1 行: 第i+1 行为M 个连续的字符,描述了草地第i 行各点的情况,保证字符是'.'和'*'中的一个。 第N+2 行: 4 个用空格隔开的整数:R1,C1,R2,C2 。

     

    输出格式:

     

    第1 行: 输出S,含义如题中所述。

     

    输入输出样例

    输入样例#1: 复制
    4 5 6
    ...*.
    ...*.
    .....
    .....
    1 3 1 5
    输出样例#1: 复制
    1
    

    说明

    样例说明:

    草地被划分成4 行5 列,奶牛在6 秒内从第1 行第3 列走到了第1 行第5 列。

    奶牛在6 秒内从(1,3)走到(1,5)的方法只有一种(绕过她面前的树)

    思路:dfs+剪枝

    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define MAXN 110
    using namespace std;
    int n,m,s,ans;
    int sx,sy,tx,ty;
    int map[MAXN][MAXN];
    int dx[4]={1,-1,0,0};
    int dy[4]={0,0,1,-1};
    void dfs(int x,int y,int tot){
        if(tot>s)    return ;
        if(x<1||x>n||y<1||y>m||map[x][y])    return ;
        if(abs(x-tx)+abs(y-ty)>s-tot)    return ;
        if(x==tx&&y==ty&&s==tot){
            ans++;
            return ;
        }
        dfs(x+1,y,tot+1);
        dfs(x-1,y,tot+1);
        dfs(x,y+1,tot+1);
        dfs(x,y-1,tot+1);
    }
    int main(){
        scanf("%d%d%d",&n,&m,&s);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++){
                char s;cin>>s;
                if(s=='.')    map[i][j]=0;
                else  map[i][j]=1; 
            }
        scanf("%d%d%d%d",&sx,&sy,&tx,&ty);
        dfs(sx,sy,0);
        cout<<ans; 
    }

    思路:记忆化搜索。

    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define MAXN 110
    using namespace std;
    int n,m,s,ans;
    int sx,sy,tx,ty;
    int map[MAXN][MAXN],f[MAXN][MAXN][20];
    int dx[4]={1,-1,0,0};
    int dy[4]={0,0,1,-1};
    void dfs(int x,int y,int tot){
        if(f[x][y][tot])    return ;
        if(tot>s)    return ;
        if(abs(x-tx)+abs(y-ty)>s-tot)    return ;
        if(x==tx&&y==ty&&tot==s){
            f[x][y][tot]=1;
            return ;
        }
        for(int i=0;i<4;i++){
            int cx=x+dx[i];
            int cy=y+dy[i];
            if(cx>=1&&cx<=n&&cy>=1&&cy<=m&&!map[cx][cy])
                dfs(cx,cy,tot+1);
            f[x][y][tot]+=f[cx][cy][tot+1];
        }
    }
    int main(){
        scanf("%d%d%d",&n,&m,&s);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++){
                char s;cin>>s;
                if(s=='.')    map[i][j]=0;
                else  map[i][j]=1; 
            }
        scanf("%d%d%d%d",&sx,&sy,&tx,&ty);
        dfs(sx,sy,0);
        cout<<f[sx][sy][0]; 
    }
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    centos7 安装prometheus node_exporter
    RMAN备份演练初级篇
    RMAN命令
    oracle数据库的归档模式
    oracle的会话(session)
    oracle的例程
    oracle热备份
    Oracle数据库归档模式的切换及其相关操作详解
    Oracle角色
    类名.class, class.forName(), getClass()区别
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/8595487.html
Copyright © 2011-2022 走看看