zoukankan      html  css  js  c++  java
  • POJ Layout

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 13706   Accepted: 6581

    Description

    Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

    Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

    Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

    Input

    Line 1: Three space-separated integers: N, ML, and MD. 

    Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

    Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

    Output

    Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

    Sample Input

    4 2 1
    1 3 10
    2 4 20
    2 3 3

    Sample Output

    27

    Hint

    Explanation of the sample: 

    There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

    The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

    Source

    思路:差分约束系统。
    一共有 ① u 到 v  的距离小于等于 d ,即 v - u < = d 。② u 到 v 的距离大于等于 d ,即 u - v > = d 。③一个奶牛对应一个位置,即 u - v > = 0 。
    然后就可以列约束关系,转化成最短路问题解决了。 
    #include<queue>
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define MAXN 1001000
    using namespace std;
    queue<int>que;
    int n,ml,md,tot,flag;
    int vis[MAXN],dis[MAXN],cnt[MAXN];
    int to[MAXN],net[MAXN],cap[MAXN],head[MAXN]; 
    void add(int u,int v,int w){ 
        to[++tot]=v;cap[tot]=w;net[tot]=head[u];head[u]=tot; 
    }
    void spfa(){
        memset(vis,0,sizeof(vis));
        memset(dis,0x7f,sizeof(dis));
        dis[1]=0;vis[1]=1;
        cnt[1]++;que.push(1);
        while(!que.empty()){
            int now=que.front();
            que.pop();vis[now]=0;
            for(int i=head[now];i;i=net[i])
                if(dis[to[i]]>dis[now]+cap[i]){
                    dis[to[i]]=dis[now]+cap[i];
                    if(!vis[to[i]]){
                        if(++cnt[to[i]]>n){ printf("-1");exit(0); }
                        vis[to[i]]=1;
                        que.push(to[i]);
                    }
                }
        }
        if(dis[n]==2139062143)    printf("-2");
        else printf("%d",dis[n]);exit(0);
    }
    int main(){
        scanf("%d%d%d",&n,&ml,&md);
        for(int i=1;i<=ml;i++){
            int a,b,d;
            scanf("%d%d%d",&a,&b,&d);
            add(a,b,d);
        }
        for(int i=1;i<=md;i++){
            int a,b,d;
            scanf("%d%d%d",&a,&b,&d);
            add(b,a,-d);
        }
        for(int i=1;i<=n;i++)    add(i,i-1,0);
        spfa();
    } 
    细雨斜风作晓寒。淡烟疏柳媚晴滩。入淮清洛渐漫漫。 雪沫乳花浮午盏,蓼茸蒿笋试春盘。人间有味是清欢。
  • 相关阅读:
    Linux curl命令详解
    drools 7 日期时间段校验
    java程序员常用查询和学习的网站
    springboot+mybatis+分页插件的使用
    Vue. 之 替换 左上角 title标签处的图标
    Github访问速度很慢的原因,以及解决方法
    vue插件总结——总有你能用上的插件
    在Java中如何高效的判断数组中是否包含某个元素
    解决vue刷新页面以后丢失store的数据
    vue路由跳转时组件data数据刷新
  • 原文地址:https://www.cnblogs.com/cangT-Tlan/p/9063621.html
Copyright © 2011-2022 走看看