zoukankan      html  css  js  c++  java
  • hdu 3038 给区间和,算出多少是错的

    参考博客

                       How Many Answers Are Wrong

    Problem Description
    TT and FF are ... friends. Uh... very very good friends -________-b

    FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

    Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

    Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

    The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

    However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

    What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

    But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
     
    Input
    Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

    Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

    You can assume that any sum of subsequence is fit in 32-bit integer.
     
    Output
    A single line with a integer denotes how many answers are wrong.
     
    Sample Input
    10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1
     
    Sample Output
    1
     

    思路:

    这题完全没想到如何用并查集来解

    总结:

    sum[i]的意义是  点i   与 点i+1   中间的点到根点的距离,巧妙使用递归寻路,更新sum与父节点
    #include <cstdio>
    #include <cstdlib>
    #include <iostream>
    using namespace std;
    int boss[200005],sum[200005];
    int fin(int x)
    {
        if(boss[x]==x)return x;
        int fx=boss[x];
        boss[x]=fin(boss[x]);
        sum[x]+=sum[fx];
        return boss[x];
    }
    int main()
    {
        int n,m,a,b,c,fa,fb,ans=0;
        while(cin>>n>>m)
        {ans=0;
        for(int i=0;i<=n;i++)boss[i]=i,sum[i]=0;//初始化boss与sum
        for(int i=0;i<m;i++)
        {
            scanf("%d %d %d",&a,&b,&c);
            fa=fin(a-1);fb=fin(b);//寻找根,并且更新sum值
            if(fa==fb)
            {
                if(sum[a-1]-sum[b]!=c)ans++;//a-1与b之间有(a,a+1,a+2...b)
            }
            else
            {
                boss[fa]=fb;
                sum[fa]=-sum[a-1]+sum[b]+c;
            }
        }
          cout<<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    正则表达式匹配负数和数字
    下拉框select chosen被遮盖
    获取JavaScript对象的方法
    管理机--Jumpserver由docker搭建
    腾讯云--腾讯云sdk-实现脚本修改腾讯云负载均衡权重
    Linux系统中使用confluence构建企业wiki
    腾讯云--对象存储cos绑定自定义域名
    python(一)python的操作符
    pytest(五)用例传fixture参数
    pytest(四)firture自定义用例预置条件
  • 原文地址:https://www.cnblogs.com/carcar/p/8574600.html
Copyright © 2011-2022 走看看