zoukankan      html  css  js  c++  java
  • HDU 2602 Bone Collector (01背包)

    Bone Collector

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 30923    Accepted Submission(s): 12722


    Problem Description
    Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
    The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
     
    Input
    The first line contain a integer T , the number of cases.
    Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
     
    Output
    One integer per line representing the maximum of the total value (this number will be less than 231).
     
    Sample Input
    1
    10
    1 2
    3 4
    5 5
    4 3
    2 1
     
    Sample Output
    14
    大致题意:有一个骨头收藏家,他喜欢收藏一些有价值的骨头,但是每个骨头是有价值的。先输入一组测试数据T,魅族测试数据第一行两个数n和m,代表有n个骨头和最大重量为m,接下来n行每行输入一个骨头的价值和重量。求不超过总量的最大价值是多少?
    思路:还是套用模版,两层for循环,使用dp公式,dp[j]=dp[j-v[i]]+w[i](当j小于最大重量时,可以装多少价值的骨头)
    #include<iostream>
    using namespace std;
    int w[1010],v[1010],f[1010];
    int main()
    {
        int T,n,m,i,j;
        cin>>T;
        while(T--)
        {
            cin>>n>>m;
            for(i=1;i<=n;i++)
                cin>>w[i];
            for(i=1;i<=n;i++)
                cin>>v[i];
            memset(f,0,sizeof(f));
            for(i=1;i<=n;i++)
            {
                for(j=m;j>=v[i];j--)
                {
                    if(f[j-v[i]]+w[i]>f[j])
                        f[j]=f[j-v[i]]+w[i];
                }
            }
            cout<< f[m] <<endl;
              
        }
        return 0;
    }
  • 相关阅读:
    Mysql中判断一个点是否落在多边形内
    Linux进阶之环境变量文件/etc/profile、/etc/bashrc、/etc/environment
    gitlab打开group_member页面500错误
    jenkins连接k8s集群
    svn备份迁移
    npm管理nodejs版本
    linux远程执行shell脚本或者python脚本无法获取远程主机的环境变量
    ansible-playbook对服务器安装阿里云日志服务agent--ilogtail
    linux安装Arachni进行web网站扫描
    nginx使用免费ssl证书
  • 原文地址:https://www.cnblogs.com/caterpillarofharvard/p/4021048.html
Copyright © 2011-2022 走看看