zoukankan      html  css  js  c++  java
  • poj3080(kmp+枚举)

    Blue Jeans
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 20163   Accepted: 8948

    Description

    The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

    As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

    A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

    Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

    Input

    Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
    • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
    • m lines each containing a single base sequence consisting of 60 bases.

    Output

    For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

    Sample Input

    3
    2
    GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
    AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
    3
    GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
    GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
    GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
    3
    CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
    AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

    Sample Output

    no significant commonalities
    AGATAC
    CATCATCAT
    

    Source

    题意:输入t组数据,每组有n个60个字符大小的字符串,求他们的最长公共子序列,在长度相同的情况下,输出字典序最小的那个,如果子序列的长度小于3,输出
    no significant commonalities
    思路:随便找一个字符串,从第1号位置一直枚举到第57号位置,然后这每一种情况都与其他n-1个字符串匹配,看每一种情况与这n-1个字符串最长可以匹配多长,在每一种情况下取与这m-1个字符串匹配最小的长度(保证它可以和这n-1个字符都匹配的上),在57种情况中取最大的长度(保证是这n个字符的最长公共子序列)。
    代码:

    #include<stdio.h>
    #include<string.h>
    char s[12][62],p[62];
    char ans[62];
    int next[62];
    int N;
    int getnext(int n)
    {
      next[0]=-1;
      int i,j=1,k=-1;
      while(j<n)
      {
        while(k>-1&&p[j]!=p[k+1])
        {
          k=next[k];
        }
        if(p[j]==p[k+1])
        k++;
        next[j]=k;
        j++;
      }
      return 0;
    }
    int kmp(int n)
    {
      getnext(n);
      int i,j,k,sum,mx=0;
      int max=100;
      for(i=1;i<N;i++)//与剩下n-1个字符匹配
      {
        j=0,k=0,mx=0;
        while(j<60&&k<n)
        {
          if(p[k]==s[i][j])//匹配时
          {
            k++;
            j++;
          }
          else
          {
            if(k==0)//回到了模式串的开头
            j++;
            else
            k=next[k-1]+1;                

          }
          if(mx<k)
          mx=k;
        }
        if(max>mx)
        max=mx;
      }
      return max;
    }
    int main()
    {
      int t;
      scanf("%d",&t);
      int i,j;
      int len;
      while(t--)
      {
        len=0;
        scanf("%d",&N);
        for(i=0;i<N;i++)
        {
          scanf("%s",s[i]);
          //printf("%s ",s[i]);
        }
        for(i=0;i<58;i++)
        {
          strcpy(p,s[0]+i);
          p[60-i]='';
          int mx=kmp(60-i);
          if(len<mx)
          {
            strncpy(ans,s[0]+i,mx);
            ans[mx]='';
            len=mx;
          }
          else if(len==mx)
          {
            p[mx]='';
            if(strcmp(p,ans)<0)
            {
              strcpy(ans,p);
              ans[mx]='';
            }
          }
        }
        if(len>=3)
        printf("%s ",ans);
        else
        printf("no significant commonalities ");
      }
      return 0;
    }

  • 相关阅读:
    Java设计模式之单例模式
    docker常用命令2
    Failed to convert value of type 'java.lang.String' to required type 'java.time.LocalDate';
    Apache RocketMQ在linux上的常用命令
    RocketMQ的broker启动失败解决
    xshell与xftp使用注意
    Springboot项目打包成jar运行2种方式
    docker常用命令记录
    MySql常用语句总结更新
    springboot启动报错start bean 'eurekaAutoServiceRegistration' NullPointerException
  • 原文地址:https://www.cnblogs.com/cglongge/p/9053106.html
Copyright © 2011-2022 走看看