zoukankan      html  css  js  c++  java
  • 平衡

    Balance
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 16423   Accepted: 10318

    Description

    Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.  It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.  Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 
    Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.  It is guaranteed that will exist at least one solution for each test case at the evaluation. 

    Input

    The input has the following structure:  • the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);  • the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm);  • on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

    Output

    The output contains the number M representing the number of possibilities to poise the balance.

    Sample Input

    2 4	
    -2 3 
    3 4 5 8
    

    Sample Output

    2

    题解:一道动态规划,一个dp解决,方程:dp[i][j+a[k]*b[i]]+=dp[i-1][j];

    #include<iostream>
    #include<cstdio>
    #include<cmath>
    #include<algorithm>
    #include<cstring>
    #include<cstdlib>
    using namespace std;
    int a[12000],b[12000];
    int dp[1100][12000];
    int main()
    {
        int n,m;
        cin>>n>>m;
        for(int i=1;i<=n;i++) cin>>a[i];
        for(int i=1;i<=m;i++) cin>>b[i];
        dp[0][6000]=1;
        for(int i=1;i<=m;i++)
        {
    	    for(int j=0;j<=12000;j++)
    	    {
    			for(int k=1;k<=n;k++)
    			{
    				dp[i][j+a[k]*b[i]]+=dp[i-1][j];
    			}
    			
    	    }
         }
        cout<<dp[m][6000];
        return 0;
    }
    
  • 相关阅读:
    CodeSmith入门教程
    AJAX调用实例
    药品监控增加表结构
    典型SQL 语句总结
    CRM中常用代码
    win2000sever+IIS5不能下载exe文件处理方法
    常用的文件对应的MIME类型
    数据库范式1NF 2NF 3NF BCNF
    多线程编程中如何更改UI值
    NHibernate学习笔记(2)—关系映射
  • 原文地址:https://www.cnblogs.com/chen-1/p/9466883.html
Copyright © 2011-2022 走看看