zoukankan      html  css  js  c++  java
  • POJ 3255 Roadblocks

    Roadblocks

     

    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 15775   Accepted: 5566

    Description

    Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

    The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersectionN.

    The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

    Input

    Line 1: Two space-separated integers: N and R 
    Lines 2..R+1: Each line contains three space-separated integers: AB, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)

    Output

    Line 1: The length of the second shortest path between node 1 and node N

    Sample Input

    4 4
    1 2 100
    2 4 200
    2 3 250
    3 4 100

    Sample Output

    450

    Hint

    Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)
     
    次短路
    #include<iostream>
    #include<queue>
    #include<cstdio>
    using namespace std;
    #define maxn 1000000
    #define inf 1<<30
    int n,m,x,y,z,num,head[maxn],dis[maxn],dis1[maxn],dis2[maxn],ans=inf,diss;
    struct Edge{
        int u,v,d,next;
    }edge[maxn];
    void add_edge(int u,int v,int d)
    {
        edge[++num].u=u;
        edge[num].v=v;
        edge[num].d=d;
        edge[num].next=head[u];
        head[u]=num;
    }
    void spfa(int now)
    {
        queue<int>que;
        bool vis[maxn];
        for(int i=1;i<=n;i++) dis[i]=inf,vis[i]=false;
        dis[now]=0; vis[now]=true;
        que.push(now);
        while(!que.empty())
        {
            int cur=que.front(); que.pop();
            for(int i=head[cur];i;i=edge[i].next)
            {
                if(dis[cur]+edge[i].d<dis[edge[i].v])
                {
                    dis[edge[i].v]=edge[i].d+dis[cur];
                    if(!vis[edge[i].v])
                    {
                        vis[edge[i].v]=true;
                        que.push(edge[i].v);
                    }
                }
            }
            vis[cur]=false;
        }
    }
    int main()
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++)
        {
            int x,y,z;
            scanf("%d%d%d",&x,&y,&z);
            add_edge(x,y,z);
            add_edge(y,x,z);
        }
        spfa(1); for(int i=1;i<=n;i++) dis1[i]=dis[i]; diss=dis[n];
        spfa(n); for(int i=1;i<=n;i++) dis2[i]=dis[i];
        for(int i=1;i<=n;i++)
        {
            for(int j=head[i];j;j=edge[j].next)
            {
                int v=edge[j].v;
                if(dis1[i]+edge[j].d+dis2[v]>diss)
                ans=min(ans,dis1[i]+edge[j].d+dis2[v]);
            }
        }
        printf("%d",ans);
        return 0;
    }
  • 相关阅读:
    C# 网络斗地主源码开源
    windows 10
    JAVA Eclipse Incorrect line ending found carriage return 怎么办
    JAVA Eclipse中如何简易的实现消息机制
    JAVA Eclipse中的Android程序如何使用线程
    JAVA Eclipse如何重新设置工作空间workspace
    JAVA Eclipse如何重命名包
    JAVA Eclipse如何修改Android程序名称
    JAVA Eclipse如何设置编程环境字体
    JAVA Eclipse如何设置点击按钮切换图片
  • 原文地址:https://www.cnblogs.com/chen74123/p/7424091.html
Copyright © 2011-2022 走看看