zoukankan      html  css  js  c++  java
  • 状态压缩DP---Hie with the Pie

    http: //acm.hust.edu.cn/vjudge/contest/view.action?cid=110044#problem/B

    Description

    The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

    Input

    Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j toi. An input value of n = 0 will terminate input.

    Output

    For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

    Sample Input

    3
    0 1 10 10
    1 0 1 2
    10 1 0 10
    10 2 10 0
    0

    Sample Output

    8

    题意:有一个出发点设为0点,然后给了n个要走的点,每个点可以经过多次,给了各个点之间的距离,求从0点出发,经过这n个点然后回到0点的最短距离。

    思路:首先使用floyd算法,求出任意两个点之间的最短距离,然后用旅行商问题的模板算法,求出最短距离。

    旅行商问题模板:给了出发点,经过所有点各一次然后回到出发点的最短距离。

    代码如下:
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    using namespace std;
    const int inf=0x3f3f3f3f;
    int d[11][11],dp[5000][11];
    
    void solve(int n)
    {
        n=n+1;
        memset(dp,inf,sizeof(dp));
        dp[(1<<n)-1][0]=0;
        for(int i=(1<<n)-1; i>=0; i--)
        {   ///旅行商问题的模板算法;
            for(int j=0; j<n; j++)
            {
                for(int k=0; k<n; k++)
                {
                    if(!(i&(1<<k)))
                        dp[i][j]=min(dp[i][j],dp[i|(1<<k)][k]+d[j][k]);
                }
            }
        }
        cout<<dp[0][0]<<endl;
    }
    
    int main()
    {
        int n;
        while(scanf("%d",&n)!=EOF&&n)
        {
            for(int i=0; i<=n; i++)
                for(int j=0; j<=n; j++)
                    cin>>d[i][j];
            for(int i=0; i<=n; i++)///floyd算法求任意两个点之间的最短距离;
            for(int j=0; j<=n; j++)
            for(int k=0; k<=n; k++)
            d[i][j]=min(d[i][j],d[i][k]+d[k][j]);
            solve(n);
        }
        return 0;
    }
  • 相关阅读:
    (转)php读写文件
    CentOS5.2下安装GCC4.1.2
    使用php模拟post提交数据
    Linux系统信息查看命令大全
    强制卸载MYSQL
    Php文件操作
    redhat linux上安装 gcc编译器
    centos5.2安装mysql6.0
    如何收缩数据库日志文件(ldf)
    浑沌的JSON,JS Object,JS Array
  • 原文地址:https://www.cnblogs.com/chen9510/p/5324195.html
Copyright © 2011-2022 走看看