zoukankan      html  css  js  c++  java
  • 2015 HUAS Summer Trainning #5~A

    Description

    Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 
     

    Input

    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 
     

    Output

    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 
     

    Sample Input

    2
    5 6 -1 5 4 -7
    7 0 6 -1 1 -6 7 -5
     

    Sample Output

    Case 1:
    14 1 4
     
    Case 2:
    7 1 6
    解题思路:这个题目的意思是求一组数的最大子段和,最大子序列是要找出由数组成的一维数组中和最大的连续子序列。  找最大子序列的方法很简单,只要前i项的和还没有小于0那么子序列就一直向后扩展,否则丢弃之前的子序列开始新的子序列,同时我们要记下各个子序列的和,最后找到和最大的子序列。如果枚举来求解显然是行不通的,他的时间复杂度约为O(n^3),改用递归也会超时,所以最好利用动态规划和分治法相结合(时间复杂度为O(n))。每一次求解时还要注意子序列的起始位置和重点位置。
    程序代码:
    #include<stdio.h> 
    int a[100005],str[100005],start[100005];
    int main()

     int t,n,i,num=1,end,max,k; 
     scanf("%d",&t); 
     while(t--)  
     {
      scanf("%d",&n);  
      for(i=1;i<=n;i++)  
      {    
       scanf("%d",&a[i]);          
      }   
      str[1]=a[1];
      start[1]=1;  
      for(i=2;i<=n;i++)  
      {   
       if(str[i-1]>=0)   
       {    
        str[i]=str[i-1]+a[i];    
        start[i]=start[i-1];    
       }   
       else   
       {    
        str[i]=a[i];    
        start[i]=i;   
       }   
      }   
      max=str[1];
      end=1;  
      for(k=2;k<=n;k++)  
      {   
       if(str[k]>max)   
       {    
        max=str[k];    
        end=k;   
       }   
      }   
      printf("Case %d: ",num);  
      num++;   
      printf("%d %d %d ",max,start[end],end);   
      if(t)          
       printf(" ");   
     } 
     return 0; 
    }
  • 相关阅读:
    ORA-06530: 引用未初始化的组合 ;
    oracle 简单的sysTimeStamp类型转date 类型
    Luogu P3388 【模板】割点(割顶)
    Luogu P2048 [NOI2010]超级钢琴
    Luogu P2657 [SCOI2009]windy数
    QZEZ第一届“饭吉圆”杯程序设计竞赛
    Luogu P2286 [HNOI2004]宠物收养场
    在平衡树的海洋中畅游(一)——Treap
    Luogu P1129 [ZJOI2007]矩阵游戏
    LOJ #559. 「LibreOJ Round #9」ZQC 的迷宫
  • 原文地址:https://www.cnblogs.com/chenchunhui/p/4721179.html
Copyright © 2011-2022 走看看