zoukankan      html  css  js  c++  java
  • 2015 HUAS Summer Trainning #5~E

    Description

    The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,...,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < ... < pik, with i1 < i2 < ... < ik. John’s problem is to find very quickly the longest rising trend.

    Input

    Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer). 
    White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

    Output

    The program prints the length of the longest rising trend. 
    For each set of data the program prints the result to the standard output from the beginning of a line.

    Sample Input

    6 
    5 2 1 4 5 3 
    3  
    1 1 1 
    4 
    4 3 2 1

    Sample Output

    3 
    1 
    1

    Hint

    There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.
    解题思路:这个题目要小心时间问题,稍不小心就会超时。还要注意的是,题目中说的最大升序并不一定是要连续的!!这是非常要注意的问题。
    程序代码:

    #include <iostream>
    #include<stdio.h>
    using namespace std;
    int a[150000],b[150000],t;
    void dog(int z)
    {
        int x,y,mid;
        x=1;
        y=t;
        while(x<=y)
        {
            mid=(x+y)/2;
            if (b[mid]==z) return ;
            else
                if (b[mid]>z) y=mid-1;
                else
                    x=mid+1;
        }
        if (x==t+1)
        {
            t++;
            b[t]=z;
        }
        else
            b[x]=z;
    }
    int main() {
        int n,i;
        while(scanf("%d",&n)!=EOF)
        {
            for(i=1;i<=n;i++)
                scanf("%d",&a[i]);
            t=1;
            b[1]=a[1];
            for(i=2;i<=n;i++)
            {
                dog(a[i]);
            }
            printf("%d ",t);
        }
        return 0;
    }

  • 相关阅读:
    Tomcat 7 的七大新特性 悟寰轩
    MapReduce提交作业常见问题 悟寰轩
    [MQ]关于ActiveMQ的配置 悟寰轩
    LinkedBlockingQueue应用实例 悟寰轩
    什么是java序列化,如何实现java序列化? 悟寰轩
    远程注入DLL的例子
    回调函数实例
    将网页保存为Stream
    删除文件或文件夹
    选择目录
  • 原文地址:https://www.cnblogs.com/chenchunhui/p/4722462.html
Copyright © 2011-2022 走看看