zoukankan      html  css  js  c++  java
  • poj 1469(简单匈牙利算法)

    题意: 最大匹配数 时候等于P

    解法: 直接匈牙利

    COURSES
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 14735   Accepted: 5816

    Description

    Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 
    • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
    • each course has a representative in the committee 

    Input

    Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 
    P N  Count1 Student1 1 Student1 2 ... Student1 Count1  Count2 Student2 1 Student2 2 ... Student2 Count2  ...  CountP StudentP 1 StudentP 2 ... StudentP CountP 
    The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.  There are no blank lines between consecutive sets of data. Input data are correct. 

    Output

    The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

    Sample Input

    2
    3 3
    3 1 2 3
    2 1 2
    1 1
    3 3
    2 1 3
    2 1 3
    1 1

    Sample Output

    YES
    NO

    Source

    #include <stdio.h>
    #include <string.h>
    #define N 310
    struct node
    {
        int to,next;
    }edge[110*300];
    
    int n,m;
    int cnt,pre[N];
    int mark[N],frt[N];
    
    void add_edge(int u,int v)
    {
        edge[cnt].to=v;
        edge[cnt].next=pre[u];
        pre[u]=cnt++;
    }
    
    int dfs(int s)
    {
        for(int p=pre[s];p!=-1;p=edge[p].next)
        {
            int v=edge[p].to;
            if(mark[v]==1) continue;
            mark[v]=1;
            if(frt[v]==-1||dfs(frt[v])==1)
            {
                frt[v]=s;
                return 1;
            }
        }
        return 0;
    }
    
    int main()
    {
        int T;
        scanf("%d",&T);
        while(T--)
        {
            cnt=0;
            memset(pre,-1,sizeof(pre));
            scanf("%d%d",&n,&m);
            for(int i=1;i<=n;i++)
            {
                int tmp;
                scanf("%d",&tmp);
                for(int j=0;j<tmp;j++)
                {
                    int key;
                    scanf("%d",&key);
                    add_edge(i,key);
                }
            }
            int sum=0;
            memset(frt,-1,sizeof(frt));
            for(int i=1;i<=n;i++)
            {
                memset(mark,0,sizeof(mark));
                sum+=dfs(i);
            }
            if(sum==n) printf("YES\n");
            else printf("NO\n");
        }
        return 0;
    }
  • 相关阅读:
    火狐URL编码问题
    Asp.net动态关键字
    charindex ,PATINDEX,contains,FREETEXT用法
    PanGu词库批量添加关键词
    Dictionary SortedList HashSet List用法
    hubbledotnet查询速度慢的问题
    asp.net 页面static变量问题
    String.Concat和String.Format用法
    .net显示今天农历的代码
    存储过程用户登录
  • 原文地址:https://www.cnblogs.com/chenhuan001/p/3014009.html
Copyright © 2011-2022 走看看