zoukankan      html  css  js  c++  java
  • hdu 2444(二分图最大匹配)

    先判断是否为二分图 , dfs 对每个点染色, 如果不会出现矛盾就说明是二分图。

    然后就是匈牙利直接水过了。。。

    The Accomodation of Students

    Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1345    Accepted Submission(s): 661

    Problem Description
    There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.
    Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.
    Calculate the maximum number of pairs that can be arranged into these double rooms.
     
    Input
    For each data set: The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.
    Proceed to the end of file.
     
    Output
    If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
     
    Sample Input
    4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6
     
    Sample Output
    No 3
     
    Source
     
    Recommend
    gaojie
     
    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    using namespace std;
    
    int n,m;
    int g[202][202];
    int flag;
    int mark[202],pre[202];
    int save[202],save1[202];
    int cnt,cnt1;
    
    void pdfs(int s,int f)
    {
        if(flag==1) return ;
        if(f==0)
            save[cnt++]=s;
        else save1[cnt1++]=s;
        mark[s]=f;
        for(int i=1;i<=n;i++)
        {
            if(g[s][i]==0) continue;
            if(mark[i]==-1)
                pdfs(i,f^1);
            else 
            {
                if(mark[i] != f^1 )
                {
                    flag=1;
                    return ;
                }
            }
        }
    }
    int dfs(int s)
    {
        for(int i=0;i<cnt1;i++)
        {
            if(mark[i]==1 || g[ save[s] ][ save1[i] ]==0) continue;
            mark[i]=1;
            if( pre[i]==-1 || dfs(pre[i])==1 )
            {
                pre[i]=s;
                return 1;
            }
        }
        return 0;
    }
    int main()
    {
        while(scanf("%d%d",&n,&m)!=EOF)
        {
            cnt=0; cnt1=0;
            flag=0;
            memset(g,0,sizeof(g));
            for(int i=0;i<m;i++)
            {
                int x,y;
                scanf("%d%d",&x,&y);
                g[x][y]=g[y][x]=1;
            }
            memset(mark,-1,sizeof(mark));
            for(int i=1;i<=n;i++)
            {
                if(mark[i]==-1)
                {
                    //save[cnt++]=i;
                    pdfs(i,0);
                    if(flag==1) break;
                }
            }
            if(flag==1) 
            {
                printf("No\n");
                continue;
            }
            memset(pre,-1,sizeof(pre));
            int sum=0;
            for(int i=0;i<cnt;i++)
            {
                memset(mark,0,sizeof(mark));
                sum+=dfs(i);
            }
            printf("%d\n",sum);
        }
        return 0;
    }
  • 相关阅读:
    第四周学习报告
    第三周学习报告
    第二周学习报告
    第一周学习报告
    大创首月学习计划
    20183122 综合实验《Python程序设计》实验报告
    20183122 实验三《Python程序设计》实验报告
    20183122 实验二《Python程序设计》实验报告
    数据存储和JSON,CSV
    python模块那点事
  • 原文地址:https://www.cnblogs.com/chenhuan001/p/3023923.html
Copyright © 2011-2022 走看看