zoukankan      html  css  js  c++  java
  • TOJ 2815 Connect them (kruskal+并查集)

    描述

    You have n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN). All connections are two-way (that is connecting computers i and j is the same as connecting computers j and i). The cost of connecting computer i and computer j is cij. You cannot connect some pairs of computers due to some particular reasons. You want to connect them so that every computer connects to any other one directly or indirectly and you also want to pay as little as possible.

    Given n and each cij , find the cheapest way to connect computers.

    输入

    There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.

    The first line of each test case contains an integer n (1 < n <= 100). Then n lines follow, each of which contains n integers separated by a space. The j-th integer of the i-th line in these n lines is cij, indicating the cost of connecting computers i and j (cij = 0 means that you cannot connect them). 0 <= cij <= 60000, cij = cji, cii = 0, 1 <= i, j <= n.

    输出

    For each test case, if you can connect the computers together, output the method in in the following fomat:

    i1 j1 i1 j1 ......

    where ik ik (k >= 1) are the identification numbers of the two computers to be connected. All the integers must be separated by a space and there must be no extra space at the end of the line. If there are multiple solutions, output the lexicographically smallest one (see hints for the definition of "lexicography small") If you cannot connect them, just output "-1" in the line.

    样例输入

    2
    3
    0 2 3
    2 0 5
    3 5 0
    2
    0 0
    0 0
    

    样例输出

    1 2 1 3
    -1

    提示

    A solution A is a line of p integers: a1, a2, ...ap.
    Another solution B different from A is a line of q integers: b1, b2, ...bq.
    A is lexicographically smaller than B if and only if:
    (1) there exists a positive integer r (r <= p, r <= q) such that ai = bi for all 0 < i < r and ar < br
    OR
    (2) p < q and ai = bi for all 0 < i <= p

    题目来源

    ZJCPC 2009

    主要是选取权值最小的边构成树,kruskal+并查集

    选完之后保存起来,还需要二次字典序排。

    #include <stdio.h>
    #include <algorithm>
    #include <iostream>
    using namespace std;
    const int MAXN=120;
    
    int N,cnt;
    int lis[MAXN];
    struct node{
        int u,v,w;
    }edge[MAXN*60];
    struct r{
        int a,b;
    }ans[MAXN];
    
    int find(int x){
        int temp=lis[x];
        while(temp!=lis[temp]){
            temp=lis[temp];
        }
        return temp;
    }
    void merge(int x, int y){
         lis[x]=y;
    }
    
    bool cmp1(node a, node b){
        if(a.w!=b.w)return a.w < b.w;
        return a.u < b.u;
    }
    bool cmp2(r a, r b){
        if(a.a!=b.a)return a.a < b.a;
        return a.b < b.b;
    }
    
    int kruskal(){
        int flag=0;
        sort(edge,edge+cnt,cmp1);
        for(int i=0; i<cnt; i++){
            int x=find(edge[i].u);
            int y=find(edge[i].v);
            if(x!=y){
                merge(x,y);
                ans[flag].a=edge[i].u;
                ans[flag].b=edge[i].v;
                flag++;
            }
        }
        return flag;
    }
    int main(int argc, char *argv[]) { int T,v; scanf("%d",&T); while(T--){ cnt=0; scanf("%d",&N); for(int i=1; i<=N; i++){ lis[i]=i; } for(int i=1; i<=N; i++){ for(int j=1; j<=N; j++){ scanf("%d",&v); if(i<j && v>0){ edge[cnt].u=i; edge[cnt].v=j; edge[cnt].w=v; cnt++; } } } int f=kruskal(); if(f!=N-1){ printf("-1 "); }else{ int flag=0; sort(ans,ans+f,cmp2); for(int i=0; i<f; i++){ if(flag)printf(" "); printf("%d %d",ans[i].a,ans[i].b); flag=1; } printf(" "); } } return 0; }
  • 相关阅读:
    内置对象 和 DropDownList时间年月日的三级联动
    复合控件 ispostback 跨页面传值
    webform简单控件和Repeater的使用
    初步认识ASP.NET WebForm
    WinForm Timer控件,三级联动[省,市,区]
    进程 线程 用户控件
    窗体容器MDI
    对话框控件 MessageBox.Show()用法补充 打开新窗体的3中模式
    winform窗体移动和阴影API
    PS学习笔记
  • 原文地址:https://www.cnblogs.com/chenjianxiang/p/3535356.html
Copyright © 2011-2022 走看看