• 路由与交换--路由器常用配置及其实验案例


    路由器常用配置命令

    1.1 路由信息协议 RIP(Routing Information Protocol )

          可以通过不断的交换信息让路由器动态的适应网络连接的变化。 同一 AS 中的路由器每 30s 与相邻的路由器交换子信息,以动态的建立路由表。这个过程可以是广播,也可以组播。RIP 协议将“距离”(即“跳数”)定义为:从一路由器到直接连接的网络的距离定义为 1。最大跳数超过 15 后被认为不可达。180s 内没更新的路由条目被认为不可达,将被删除。

    1.2 为接口分配 IP 地址、描述端口

    Router>enable
    Router#conf t
    Router(config)#interface e0
    Router(config-if)#ip add 192.168.1.1 255.255.255.0  //设置IP地址和子网掩码
    Router(config-if)#no shutdown
    Router(config-if)#description to-pc1  //描述端口内容为“to-pc1”

    1.3 为一个接口分配多个 IP 地址

    Router(config)#interface e0
    Router(config-if)#ip add 192.168.1.1 255.255.255.0  //设置IP地址和子网掩码
    Router(config-if)#ip add 192.168.2.1 255.255.255.0 secondary  //假设e0接口已经分配了192.168.1.1~253,但此时还有主机要加入到网络中,则在接口添加一个辅助IP来适应网络扩张,此辅助地址指明另一个子网被关联到e0。

    静态路由配置

          利用本地外出接口配置静态路由

    Router(config)#ip route 10.6.0.0 255.255.0.0 s1 //目标网络 目标网络掩码地址 外出接口

          利用下一跳 IP 地址配置静态路由

    Router(config)#ip route 10.6.0.0 255.255.0.0 10.5.0.1  //目标网络 目标网络掩码地址 下一跳地址

          静态默认路由:转发的 IP 数据包中的目的地址找不到对应路由时,路由器就按照所指定的默认路由进行转发

    Router(config)#ip route 0.0.0.0 0.0.0.0 10.2.0.1  //规定用0填充目的网络和目的网络掩码,10.2.0.1是指定的下一跳地址

          静态默认网络配置:配置一条到某个网络的路由,将其作为候选默认路由

    Router(config)#ip default-network 10.2.0.0  //10.2.0.0是默认路由的网络号

          ip default-network 只能用于有类别的地址,但它比 ip route 0.0.0.0 0.0.0.0 更有灵活性,更加适用于复杂网络。

          路由器默认网关配置

    Router(config)#no ip route  //关闭路由功能,使其变为一台客户计算机
    Router(config)#ip default-gateway 10.1.1.1  //配置缺省网关为10.1.1.1

          浮动静态路由:通过配置浮动静态路由,使静态路由具有一定限度的适应能力。通过设置管理距离来实现。主路由器失效时,启用浮动静态路由

    Router(config)#ip route 10.0.0.0 255.0.0.0 1.1.1.1 130  //130是管理距离

    2.1 静态路由配置

    拓扑示意图 

          1、配置 R1

    R1(config)#int e0
    R1(config-if)#ip add 1.1.1.1 255.0.0.0
    R1(config-if)#no shut
    R1(config)#int s0
    R1(config-if)#ip add 2.1.1.1 255.0.0.0
    R1(config-if)#clock rate 64000  //R1作为DCE可以规定时钟频率
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#ip route 0.0.0.0 0.0.0.0 2.1.1.2  //默认路由:0,0,下一跳
    或R1(config)#ip route 3.0.0.0 255.0.0.0 2.1.1.2  //静态路由:目标网络,掩码,下一跳

          2、配置 R2

    R2(config)#int e0
    R2(config-if)#ip add 3.1.1.1 255.0.0.0
    R2(config-if)#no shut
    R2(config)#int s0
    R2(config-if)#ip add 2.1.1.2 255.0.0.0
    R2(config-if)#no shut
    R2(config-if)#exit
    R2(config)#ip route 0.0.0.0 0.0.0.0 2.1.1.1  //默认路由:0,0,下一跳
    或R2(config)#ip route 1.0.0.0 255.0.0.0 2.1.1.1  //静态路由:目标网络,掩码,下一跳

          3、配置 PC1 和 PC2 的网关分别为 R1 和 R2 的 E0 的地址

    2.2 配置子接口 

    Router(config)#inter f0/0
    Router(config-if)#no shut  //先启用端口再配置子接口
    Router(config-if)#int f0/0.1
    Router(config-subif.1)#encapsulation dot1q VLAN号  //配置子接口二层属性
    Router(config-subif.1)#ip add ip地址 子网掩码  //配置子接口三层属性
    Router(config-if)#int f0/0.2
    Router(config-subif.2)#encapsulation dot1q VLAN号
    Router(config-subif.2)#ip add ip地址 子网掩码
    Router(config-subif.2)#exit

    2.3 VLAN 之间单臂路由 

          1、在 SW1 上划分 VLAN,并将端口分配给 2 个 VLAN

    SW1#vlan database
    SW1(vlan)#vlan 20
    SW1(vlan)#vlan 30
    SW1(vlan)#exit
    SW1#conf t
    SW1(config)#int fe0/2
    SW1(config-if)#switchport mode access
    SW1(config-if)#switchport access vlan 20
    SW1(config-if)#exit
    SW1(config)#int fe0/3
    SW1(config-if)#switchport mode access
    SW1(config-if)#switchport access vlan 30
    SW1(config-if)#exit

          2、对 SW1 的 fe0/1 口进行中继设置,并允许所有 VLAN 数据通过

    SW1(config)#int fe0/1
    SW1(config-if)#no shut
    SW1(config-if)#switchport mode trunk
    SW1(config-if)#switchport trunk allowed vlan 20,30  //或allowed vlan all,如果允许所有VLAN数据通过,也可以省略此句。
    SW1(config-if)#end
    SW1#copy running strat

          3、设置 R1 的 fe0/1 口的子接口

    R1(config)#inter fe0/1
    R1(config-if)#no shut 
    R1(config-if)#int f0/1.1
    R1(config-subif.1)#encapsulation dot1q 20
    R1(config-subif.1)#ip add 20.1.1.1 255.0.0.0
    R1(config-if)#int f0/1.2
    R1(config-subif.2)#encapsulation dot1q 30
    R1(config-subif.2)#ip add 30.1.1.1 255.0.0.0
    R1(config-subif.2)#end
    R1#copy running start

          4、设置 pc1 和 pc2 的 IP 地址和网关

          pc1 的 IP 地址 20.1.1.2,网关即子接口 fe0/1.1 地址 20.1.1.1。pc2 的 IP 地址 30.1.1.2,网关即子接口 fe0/1.2 地址 30.1.1.1。

    3 RIP 路由配置

          启动 RIP 协议

    Router(config)#router rip

          设置 RIP 协议覆盖的网络范围

    Router(config-router)#network 网络号

          路由器默认使用 RIPv1,由于其局限性,常常需要使用更高版本的 RIP,例如:

    Router(config)#router rip
    Router(config-router)#version 2
    Router(config-router)#no auto-summary  //关闭自动汇总路由的功能
    RIP是一个广播协议,为了使路由更新报文能到达非广播网络,必须相应配置路由器。
    Router(config-router)#neighbor ip地址  //ip地址为路由器所连接的其他路由器的接口地址

          RIP 可以通过水平分割、毒性逆转等方法防止路由环路(自己宣告出去的路由,又被自己接受并更新路由表) 

          1、配置前,通过 show ip route 命令查看路由表,验证 PC 间能否 ping 通

          2、配置路由器,以 R2 为例:

    R2(config)#int e0
    R2(config-if)#ip add 30.0.0.1 255.0.0.0
    R2(config-if)#no shut
    R2(config)#int s0
    R2(config-if)#ip add 20.0.0.2 255.0.0.0
    R2(config-if)#clock rate 64000
    R2(config-if)#no shut
    R2(config)#int s1
    R2(config-if)#ip add 40.0.0.1 255.0.0.0
    R2(config-if)#clock rate 64000
    R2(config-if)#no shut

          3、在 R2 上配置 RIP 协议

    R2(config)#router rip
    R2(config-router)#network 20.0.0.0
    R2(config-router)#network 30.0.0.0
    R2(config-router)#network 40.0.0.0
    R2(config-router)#end

          4、同理配置 R1 和 R3

          5、配置 PC 的 IP 地址和网关(所连接的路由器的 E0 口 IP 地址)

          6、再次查看路由表,并 pc 互 ping。

    4 OSPF 路由配置

          启动 OSPF 协议进程,定义路由器所处网络

    Router(config)#router ospf 20    //具有相同进程号的路由器之间才会产生邻居邻接关系,每个进程维护一个数据库,1~65535。
    Router(config-router)#network 211.83.242.0 0.0.0.255 area 0  //network 网络号 反掩码 area 区域号
    Router(config-router)#network 211.83.230.0 0.0.0.255 area 1
    Router(config-router)#exit
    Router(config)#show ip ospf neighbor  //查看OSPF路由表信息

          配置 OSPF 接口连接的网络类型

    Router(config-if)#ip ospf netowrk broadcast|non-broadcast|point-to-multipoint|point-to-point

          非广播网络连接时,指定邻居节点地址:

    Router(config-router)#neighbor 10.0.1.3

    4.1 以太网单一区域 OSPF 路由配置 

          以 R1 为例:

    R1(config)#int fa0/0
    R1(config-if)#ip add 192.168.1.1 255.255.255.0
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#int fa1/0
    R1(config-if)#ip add 10.0.0.1 255.0.0.0
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#int loopback 0
    R1(config-if)#ip add 1.1.1.1 255.255.255.0
    R1(config-if)#ip ospf priority 2 
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#router ospf 100  //各个路由器进程号必须一致
    R1(config-router)#network 1.1.1.0 0.0.0.255 area 0  //使用反掩码,区域号为0表示骨干区域
    R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
    R1(config-router)#network 10.0.0.0 0.255.255.255 area 0
    R1(config-router)#end
    R1#show ip route  //各个路由器配置完后,可以用show ip ospf neighbor查看邻居信息

    4.2 OSPF 多区域路由配置 

          R1 的配置

    R1(config)#int f0/1
    R1(config-if)#ip add 192.1.0.129 255.255.255.192
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#int s0/1
    R1(config-if)#ip add 192.200.10.5 255.255.255.252
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#router ospf 100
    R1(config-router)#network 192.200.10.4 0.0.0.3 area 0
    R1(config-router)#network 192.1.0.128 0.0.0.63 area 1
    R1(config-router)#end

          R2 的配置与 R1 类似

          R3 的配置

    R3(config)#int f0/1
    R3(config-if)#ip add 192.1.0.130 255.255.255.192
    R3(config-if)#exit
    R3(config)#router ospf 100
    R3(config-router)#network 192.1.0.128 0.0.0.63 area 1

          R4 的配置与 R3 类似

          检查配置

    R1#show ip route //查看与R1同一OSPF进程的条目
    R1#show ip ospf //查看R1上OSPF路由信息
    R1#show ip ospf neighbor //查看邻接点信息,是否有DR和BDR
    R1#show ip ospf database //查看OSPF连接状态数据库

    4.3 OSPF 虚拟链路配置

          OSPF 网络中,不同 area 之间的数据转发必须通过 area 0,如果一个 area 与 area 0 之间不直接相连时,就需要配置虚链路。 

          1、各路由器接口地址配置,loopback 0 地址配置(Router ID)

          2、各路由器 OSPF 进程配置,定义所处网络

          3、show ip route 查看路由表,发现 R1 没有去往 R4 的路由表,此时需要配置 R2 到 R3 的虚链路

          4、配置虚链路

    R2(config)#router ospf 1
    R2(config-router)#area 2 virtual-link R3-ID  //虚拟链路所在的区域,对方(R3)路由器ID
    R3(config)#router ospf 1
    R3(config-router)#area 2 virtual-link R2-ID

          5、再次查看路由表,链路创建成功

    上机实战

    5.1 静态路由和默认路由 

          实验要求:在 R1 和 R2 上分别配置静态路由和默认路由,使 PC1 和 PC2 能 ping 通,通过查看路由器的路由表判定是否静态路由配置成功。

    对路由器 R1 进行配置

    Router>enable
    Router#conf t
    Router(config)#hostname route1
    route1(config)#int fa0/0
    route1(config-if)#ip add 10.0.0.1 255.255.255.0
    route1(config-if)#no shut
    route1(config-if)#exit
    route1(config)#int se2/0
    route1(config-if)#ip add 1.1.1.1 255.255.255.0
    route1(config-if)#no shut
    route1(config-if)#exit
    route1(config)#ip route 20.0.0.0 255.255.255.0 1.1.1.2  //静态路由
    route1(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2  //默认路由

    对路由器 R2 进行配置

    Router>enable
    Router#conf t
    Router(config)#int fa0/0
    Router(config-if)#ip add 20.0.0.1 255.255.255.0
    Router(config-if)#no shut
    Router(config-if)#exit
    Router(config)#int se2/0
    Router(config-if)#ip add 1.1.1.2 255.255.255.0
    Router(config-if)#clock rate 64000
    Router(config-if)#no shut
    Router(config-if)#exit
    Router(config)#ip route 10.0.0.0 255.255.255.0 1.1.1.1
    Router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.1

    查看路由器的配置是否生效 

    给两台 PC 分配好 IP,并设置其网关,然后验证他们之间的连通性 

    5.2 静态路由综合练习 

          要求:通过静态路由和默认路由的设置,使所有 PC 能互通。

          说明:

                1、PC1、2 属于 10.0.0.0/8 网段,PC3、4 属于 20.0.0.0/8 网段,PC5 属于 50.0.0.0/8 网段,PC6 属于 60.0.0.0/8 网段。

                2、合理配置路由器和交换机相关接口 IP 地址。

                3、各路由器通过串口连接,合理配置时钟频率。

                4、合理配置静态路由和默认路由。

                5、通过 show ip route 查看各路由器路由表,确认路由信息。

                6、正确配置各 PC 的网关。

    对交换机 sw1 进行配置

    Switch>enable
    Switch#conf t
    Switch(config)#hostname switch1
    switch1(config)#int fa0/3
    switch1(config-if)#switchport mode trunk
    switch1(config-if)#switchport mode trunk

    对交换机 sw2 进行配置

    Switch>enable
    Switch#conf t
    Switch(config)#hostname switch2
    switch2(config)#int fa0/1
    switch2(config-if)#switchport mode trunk

    对路由器 route1 进行配置

    Router>enable
    Router#conf t
    Router(config)#hostname route1
    route1(config)#int fa0/0
    route1(config-if)#ip add 10.0.0.1 255.0.0.0
    route1(config-if)#no shut
    route1(config-if)#exit
    route1(config)#int fa1/0
    route1(config-if)#ip add 20.0.0.1 255.0.0.0
    route1(config-if)#no shut
    route1(config-if)#exit
    route1(config)#int se2/0
    route1(config-if)#ip add 1.1.1.1 255.255.255.0
    route1(config-if)#clock rate 64000
    route1(config-if)#no shut
    route1(config-if)#exit
    route1(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2

    对路由器 route2 进行配置

    Router>enable
    Router#conf t
    Router(config)#hostname route2
    route2(config)#int se2/0
    route2(config-if)#ip add 1.1.1.2 255.255.255.0
    route2(config-if)#no shut
    route2(config-if)#exit
    route2(config)#int fa1/0
    route2(config-if)#ip add 50.0.0.1 255.0.0.0
    route2(config-if)#no shut
    route2(config-if)#exit
    route2(config)#int se3/0
    route2(config-if)#ip add 2.2.2.1 255.255.255.0
    route2(config-if)#no shut
    route2(config-if)#exit
    route2(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.1
    route2(config)#ip route 0.0.0.0 0.0.0.0 2.2.2.2

    对路由器 route3 进行配置

    Router>enable
    Router#conf t
    Router(config)#hostname route3
    route3(config)#int se2/0
    route3(config-if)#ip add 2.2.2.2 255.255.255.0
    route3(config-if)#clock rate 64000
    route3(config-if)#no shut
    route3(config-if)#exit
    route3(config)#int fa0/0
    route3(config-if)#ip add 60.0.0.1 255.0.0.0
    route3(config-if)#no shut
    route3(config-if)#exit
    route3(config)#ip route 0.0.0.0 0.0.0.0 2.2.2.1

          给各台 PC 分配 IP,并设置其网关,然后验证他们之间的通信,这里以 PC1 为例去 ping 其他 PC 

          对上面的部分配置进行一个简单的说明:默认路由用在末梢网络上,中间路由器一般不采用默认路由,但即使用默认路由去配置中间路由器,在客户端看来也是没有区别的,唯一的区别在于,如果去追逐数据包的发送路径,在经过中间路由器的时候会多走一个来回,拿这样一个简单的网络拓扑来说明,PC1 --R1--R2--PC2,如果R2采用默认路由,那么 PC1 去 ping PC2,数据包的路径是这样的:PC1->R1->R2->R1->R2->PC2,在 R2 上多走一个来回。客户端并不关心其内部路径,只关心能否到达目标主机,但对路由器来说,增大了它的负荷,这里完全是为了简化配置,建议大家非末梢网络的路由器,严格的按照静态路由去配置。 

    5.3 单臂路由路由综合练习

          要求:通过单臂路由、静态路由、默认路由的设置,使所有 PC 能互通。

          说明:

                1、PC1~PC4 分别属于 VLAN10/20/30/40。

                2、PC1~PC7 分别属于 10.0.0.0/8~70.0.0.0/8 网段。

                3、合理配置路由器和交换机相关接口 IP 地址。

                4、通过串口连接的路由器,合理配置时钟频率。

                5、根据需要,合理配置单臂路由、静态路由或默认路由。

                6、通过 show ip route 查看各路由器路由表,确认路由信息。

                7、正确配置各 PC 的网关。

    对交换机 sw1 进行配置

    Switch>enable
    Switch#conf t
    Switch(config)#hostname switch1
    switch1(config)#vlan 10
    switch1(config-vlan)#exit
    switch1(config)#vlan 20
    switch1(config-vlan)#exit
    switch1(config)#int fa0/1
    switch1(config-if)#switchport mode access
    switch1(config-if)#switchport access vlan 10
    switch1(config-if)#exit
    switch1(config)#int fa0/2
    switch1(config-if)#switchport mode access
    switch1(config-if)#switchport access vlan 20
    switch1(config-if)#exit
    switch1(config)#int fa0/3
    switch1(config-if)#switchport mode trunk
    switch1(config-if)#no shut

    对交换机 sw2 进行配置

    Switch>enable
    Switch#conf t
    Switch(config)#hostname switch2
    switch2(config)#vlan 30
    switch2(config-vlan)#exit
    switch2(config)#vlan 40
    switch2(config-vlan)#exit
    switch2(config)#int fa0/1
    switch2(config-if)#switchport mode access
    switch2(config-if)#switchport access vlan 30
    switch2(config-if)#exit
    switch2(config)#int fa0/2
    switch2(config-if)#switchport mode access
    switch2(config-if)#switchport access vlan 40
    switch2(config-if)#exit
    switch2(config)#int fa0/3
    switch2(config-if)#switchport mode trunk
    switch2(config-if)#no shut

    对路由器 R1 进行配置

    Router>enable
    Router#conf t
    Router(config)#hostname R1
    R1(config)#int fa0/0
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#int fa0/0.1
    R1(config-subif)#encapsulation dot1q 10
    R1(config-subif)#ip add 10.0.0.1 255.0.0.0
    R1(config-subif)#no shut
    R1(config-subif)#exit
    R1(config)#int fa0/0.2
    R1(config-subif)#encapsulation dot1q 20
    R1(config-subif)#ip add 20.0.0.1 255.0.0.0
    R1(config-subif)#no shut
    R1(config-subif)#exit
    R1(config)#int fa1/0
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#int fa1/0.1
    R1(config-subif)#encapsulation dot1q 30
    R1(config-subif)#ip add 30.0.0.1 255.0.0.0
    R1(config-subif)#no shut
    R1(config-subif)#exit
    R1(config)#int fa1/0.2
    R1(config-subif)#encapsulation dot1q 40
    R1(config-subif)#ip add 40.0.0.1 255.0.0.0
    R1(config-subif)#no shut
    R1(config-subif)#exit
    R1(config)#int se2/0
    R1(config-if)#ip add 1.1.1.1 255.255.255.0
    R1(config-if)#clock rate 64000
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#int se3/0
    R1(config-if)#ip add 2.2.2.1 255.255.255.0
    R1(config-if)#clock rate 64000
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2
    R1(config)#ip route 0.0.0.0 0.0.0.0 2.2.2.2

    对路由器 R2 进行配置

    Router>enable
    Router#conf t
    Router(config)#hostname R2
    R2(config)#int se2/0
    R2(config-if)#ip add 1.1.1.2 255.255.255.0
    R2(config-if)#no shut
    R2(config-if)#exit
    R2(config)#int fa0/0
    R2(config-if)#ip add 50.0.0.1 255.0.0.0
    R2(config-if)#no shut
    R2(config-if)#exit
    R2(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.1

    对路由器 R3 进行配置

    Router>enable
    Router#conf t
    Router(config)#int se2/0
    Router(config-if)#ip add 2.2.2.2 255.255.255.0
    Router(config-if)#no shut
    Router(config-if)#exit
    Router(config)#int se3/0
    Router(config-if)#ip add 3.3.3.1 255.255.255.0
    Router(config-if)#clock rate 64000
    Router(config-if)#no shut
    Router(config-if)#exit
    Router(config)#int fa0/0
    Router(config-if)#ip add 60.0.0.1 255.0.0.0
    Router(config-if)#no shut
    Router(config-if)#exit
    Router(config)#ip route 0.0.0.0 0.0.0.0 3.3.3.2
    Router(config)#ip route 0.0.0.0 0.0.0.0 2.2.2.1

    对路由器 R4 进行配置

    Router>enable
    Router#conf t
    Router(config)#hostname R4
    R4(config)#int se2/0
    R4(config-if)#ip add 3.3.3.2 255.255.255.0
    R4(config-if)#no shut
    R4(config-if)#exit
    R4(config)#int fa0/0
    R4(config-if)#ip add 70.0.0.1 255.0.0.0
    R4(config-if)#no shut
    R4(config-if)#exit
    R4(config)#ip route 0.0.0.0 0.0.0.0 3.3.3.1

          给各台 PC 分配 IP,并设置其网关,然后验证他们之间的通信。这里以 PC1 为例,让 PC1 去 ping 其他 PC 

    5.4 多区域 OSPF 路由配置

          实验要求:

                1、配置多区域 OSPF。指定各路由器的物理接口 IP 地址、环回接口 IP 地址和所处区域,观察自动选举 DR 和 BDR 的结果。

                2、各个路由器分别连接一台 PC,使得各个 PC 能相互连同。观察各路由器路由表,通过 OSPF 学习的路由表条目信息。

    对路由器 R1 进行配置

    Router>enable
    Router#conf t
    Router(config)#hostname R1
    R1(config)#int fa0/0
    R1(config-if)#ip add 10.0.0.1 255.255.255.0
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#int se2/0
    R1(config-if)#ip add 1.1.1.1 255.255.255.0
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#int se3/0
    R1(config-if)#ip add 2.2.2.1 255.255.255.0
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#int loopback 0
    R1(config-if)#ip add 11.1.1.1 255.255.255.0
    R1(config-if)#ip ospf prio 2
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#route ospf 100
    R1(config-router)#network 10.0.0.0 0.0.0.255 area 1
    R1(config-router)#network 11.1.1.0 0.0.0.255 area 0
    R1(config-router)#network 2.2.2.0 0.0.0.255 area 0
    R1(config-router)#network 1.1.1.0 0.0.0.255 area 2

    对路由器 R2 进行配置

    Router>enable
    Router#conf t
    Router(config)#hostname R2
    R2(config)#int fa0/0
    R2(config-if)#ip add 30.0.0.1 255.255.255.0
    R2(config-if)#no shut
    R2(config-if)#exit
    R2(config)#int se2/0
    R2(config-if)#ip add 2.2.2.2 255.255.255.0
    R2(config-if)#no shut
    R2(config)#exit
    R2(config)#int se3/0 
    R2(config-if)#ip add 3.3.3.1 255.255.255.0
    R2(config-if)#no shut
    R2(config-if)#exit
    R2(config)#int loopback 0
    R2(config-if)#ip add 12.1.1.1 255.255.255.0
    R2(config-if)#ip ospf prio 2
    R2(config-if)#no shut
    R2(config-if)#exit
    R2(config)#route ospf 100
    R2(config-router)#network 12.1.1.0 0.0.0.255 area 0
    R2(config-router)#network 30.0.0.0 0.0.0.255 area 3
    R2(config-router)#network 2.2.2.0 0.0.0.255 area 0
    R2(config-router)#network 3.3.3.0 0.0.0.255 area 4

    对路由器 R3 进行配置

    Router>enable
    Router#conf t
    Router(config)#hostname R3
    R3(config)#int fa0/0
    R3(config-if)#ip add 20.0.0.1 255.255.255.0
    R3(config-if)#no shut
    R3(config-if)#exit
    R3(config)#int se2/0
    R3(config-if)#ip add 1.1.1.2 255.255.255.0
    R3(config-if)#no shut
    R3(config-if)#exit
    R3(config)#int loopback 0
    R3(config-if)#ip add 13.1.1.1 255.255.255.0
    R3(config-if)#ip ospf prio 2
    R3(config-if)#no shut
    R3(config-if)#exit
    R3(config)#route ospf 100
    R3(config-router)#network 20.0.0.0 0.0.0.255 area 2
    R3(config-router)#network 13.1.1.0 0.0.0.255 area 2
    R3(config-router)#network 1.1.1.0 0.0.0.255 area 2

    对路由器 R4 进行配置

    Router>enable
    Router#conf t
    Router(config)#hostname R4
    R4(config)#int se2/0
    R4(config-if)#ip add 3.3.3.2 255.255.255.0
    R4(config-if)#no shut
    R4(config-if)#exit
    R4(config)#int fa0/0
    R4(config-if)#ip add 40.0.0.1 255.255.255.0
    R4(config-if)#no shut
    R4(config-if)#exit
    R4(config)#int loopback 0
    R4(config-if)#ip add 14.1.1.1 255.255.255.0
    R4(config-if)#ip ospf prio 2
    R4(config-if)#no shut
    R4(config-if)#exit
    R4(config)#route ospf 100
    R4(config-router)#network 14.1.1.0 0.0.0.255 area 4
    R4(config-router)#network 3.3.3.0 0.0.0.255 area 4
    R4(config-router)#network 40.0.0.0 0.0.0.255 area 4

          给各台 PC 分配 IP,并设置其网关,然后验证他们之间的通信 

    以 R1 为例,查看其路由表的路由信息 

    5.5 路由配置综合练习 

          实验要求:

                1、PC1 和 PC2 在不同 VLAN 和不同 IP 网段。

                2、各 PC 之间能相互访问,但是要求:

                      (1)PC1 和 PC2 要访问 PC3 必须经由 R3 访问。

                      (2)PC3 无论访问哪个PC都经由R1。

                3、合理配置各设备,并通过仿真软件的模拟模式观察数据包的路径是否符合要求。

    对交换机 sw1 进行配置

    Switch>enable
    Switch#conf t
    Switch(config)#vlan 10
    Switch(config-vlan)#exit
    Switch(config)#vlan 20
    Switch(config-vlan)#exit
    Switch(config)#int fa0/2
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 10
    Switch(config-if)#exit
    Switch(config)#int fa0/1
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 20
    Switch(config-if)#exit
    Switch(config)#int fa0/3
    Switch(config-if)#switchport mode trunk

    对路由器 R1 进行配置

    Router>enable
    Router#conf t
    Router(config)#hostname R1
    R1(config)#int fa0/0
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#int fa0/0.1
    R1(config-subif)#encapsulation dot1q 10
    R1(config-subif)#ip add 10.0.0.1 255.255.255.0
    R1(config-subif)#no shut
    R1(config-subif)#exit
    R1(config)#int fa0/0.2
    R1(config-subif)#encapsulation dot1q 20
    R1(config-subif)#ip add 20.0.0.1 255.255.255.0
    R1(config-subif)#no shut
    R1(config-if)#exit
    R1(config)#int se2/0
    R1(config-if)#ip add 1.1.1.1 255.255.255.0
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#int se3/0
    R1(config-if)#ip add 2.2.2.1 255.255.255.0
    R1(config-if)#no shut
    R1(config-if)#exit
    R1(config)#ip route 30.0.0.0 255.255.255.0 2.2.2.2
    R1(config)#ip route 40.0.0.0 255.255.255.0 2.2.2.2

    对路由器 R2 进行配置

    Router>enable
    Router#conf t
    Router(config)#hostname R2
    R2(config)#int se2/0
    R2(config-if)#ip add 1.1.1.2 255.255.255.0
    R2(config-if)#no shut
    R2(config-if)#exit
    R2(config)#int fa0/0
    R2(config-if)#ip add 30.0.0.1 255.255.255.0
    R2(config-if)#no shut
    R2(config-if)#exit
    R2(config)#int se3/0
    R2(config-if)#ip add 3.3.3.2 255.255.255.0
    R2(config-if)#no shut
    R2(config-if)#exit
    R2(config)#ip route 40.0.0.0 255.255.255.0 1.1.1.1
    R2(config)#ip route 0.0.0.0 0.0.0.0 3.3.3.1
    R2(config)#ip route 10.0.0.0 255.255.255.0 1.1.1.1
    R2(config)#ip route 20.0.0.0 255.255.255.0 1.1.1.1

    对路由器 R3 进行配置

    Router>enable
    Router#conf t
    Router(config)#hostname R3
    R3(config)#int se2/0
    R3(config-if)#ip add 2.2.2.2 255.255.255.0
    R3(config-if)#no shut
    R3(config)#exit
    R3(config)#int se3/0
    R3(config-if)#ip add 3.3.3.1 255.255.255.0
    R3(config-if)#no shut
    R3(config-if)#exit
    R3(config)#int fa0/0
    R3(config-if)#ip add 40.0.0.1 255.255.255.0
    R3(config-if)#no shut
    R3(config-if)#exit
    R3(config)#ip route 30.0.0.0 255.255.255.0 3.3.3.2
    R3(config)#ip route 10.0.0.0 255.255.255.0 2.2.2.1
    R3(config)#ip route 20.0.0.0 255.255.255.0 2.2.2.1

          给各台 PC 分配 IP,并设置其网关,然后验证他们之间的通信 

          对于 PC1 和 PC2 访问 PC3 必须经过 R3,PC3 访问哪个 PC 都必须经过 R1 的验证不是很好演示,如果演示需要截图太多,大家可以按照上面的命令对相应的交换机和路由器配置好后,按照下图的方法自行验证。先点击右下角的机器人的图标,然后用 PC1 去 ping 主机 PC3,再连续点击 Capture / Forward 查看 icmp 数据包的路径,其他的类似,这里不再累赘  

  • 相关阅读:
    PHP 批量删除 基本思路
    spark yarn 集群提交kafka代码
    scala高阶函数类型推断什么时候失效?
    一文读懂 超简单的spark structured stream 源码解读
    一文读懂spark yarn集群搭建
    linux平台 spark standalone集群 使用 start-all,stop-all 管理集群的启动和退出
    linux平台使用spark-submit以cluster模式提交spark应用到standalone集群
    windows平台使用spark-submit以client方式提交spark应用到standalone集群
    spark使用idea以client模式提交应用到standalone集群
    spark standalone集群部署 实践记录
  • 原文地址:https://www.cnblogs.com/chenjin2018/p/10160617.html
走看看 - 开发者的网上家园