zoukankan      html  css  js  c++  java
  • HDU-2389

    Rain on your Parade

    Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 655350/165535 K (Java/Others)
    Total Submission(s): 2979    Accepted Submission(s): 931


    Problem Description
    You’re giving a party in the garden of your villa by the sea. The party is a huge success, and everyone is here. It’s a warm, sunny evening, and a soothing wind sends fresh, salty air from the sea. The evening is progressing just as you had imagined. It could be the perfect end of a beautiful day.
    But nothing ever is perfect. One of your guests works in weather forecasting. He suddenly yells, “I know that breeze! It means its going to rain heavily in just a few minutes!” Your guests all wear their best dresses and really would not like to get wet, hence they stand terrified when hearing the bad news.
    You have prepared a few umbrellas which can protect a few of your guests. The umbrellas are small, and since your guests are all slightly snobbish, no guest will share an umbrella with other guests. The umbrellas are spread across your (gigantic) garden, just like your guests. To complicate matters even more, some of your guests can’t run as fast as the others.
    Can you help your guests so that as many as possible find an umbrella before it starts to pour?

    Given the positions and speeds of all your guests, the positions of the umbrellas, and the time until it starts to rain, find out how many of your guests can at most reach an umbrella. Two guests do not want to share an umbrella, however.
     
    Input
    The input starts with a line containing a single integer, the number of test cases.
    Each test case starts with a line containing the time t in minutes until it will start to rain (1 <=t <= 5). The next line contains the number of guests m (1 <= m <= 3000), followed by m lines containing x- and y-coordinates as well as the speed si in units per minute (1 <= si <= 3000) of the guest as integers, separated by spaces. After the guests, a single line contains n (1 <= n <= 3000), the number of umbrellas, followed by n lines containing the integer coordinates of each umbrella, separated by a space.
    The absolute value of all coordinates is less than 10000.
     
    Output
    For each test case, write a line containing “Scenario #i:”, where i is the number of the test case starting at 1. Then, write a single line that contains the number of guests that can at most reach an umbrella before it starts to rain. Terminate every test case with a blank line.
     
    Sample Input
    2
    1
    2
    1 0 3
    3 0 3
    2
    4 0
    6 0
    1
    2
    1 1 2
    3 3 2
    2
    2 2 
     
    Sample Output
    Scenario #1: 2
    Scenario #2: 2
     
    Source
     
    Recommend
    lcy
    /**
              题意:m个人,n把伞,并且每个人的位置上有个雨下落的速度,然后看能有
                        多少人能够分到雨伞
              做法:二分图最大匹配;
                        匈牙利算法会超时,时间复杂度是O(VE),
                        Hopcroft-Carp 算法 时间复杂度是 O(sqrt(n)*E)
    **/
    #include<stdio.h>
    #include<queue>
    #include<iostream>
    #include<string.h>
    #include<math.h>
    using namespace std;
    #define eps 1e-6
    
    const int MAXN=3005;
    const int INF=1<<28;
    int g[MAXN][MAXN],Mx[MAXN],My[MAXN],Nx,Ny;
    int dx[MAXN],dy[MAXN],dis;
    bool vst[MAXN];
    struct Node1
    {
        int x,y,s;
    } guests[MAXN];
    struct Node2
    {
        int x,y;
    } um[MAXN];
    double distance(Node1 a,Node2 b)
    {
        double x=a.x-b.x;
        double y=a.y-b.y;
    
        return sqrt(x*x+y*y);
    }
    bool searchP()
    {
        queue<int>Q;
        dis=INF;
        memset(dx,-1,sizeof(dx));
        memset(dy,-1,sizeof(dy));
        for(int i=0; i<Nx; i++)
            if(Mx[i]==-1)
            {
                Q.push(i);
                dx[i]=0;
            }
        while(!Q.empty())
        {
            int u=Q.front();
            Q.pop();
            if(dx[u]>dis)  break;
            for(int v=0; v<Ny; v++)
                if(g[u][v]&&dy[v]==-1)
                {
                    dy[v]=dx[u]+1;
                    if(My[v]==-1)  dis=dy[v];
                    else
                    {
                        dx[My[v]]=dy[v]+1;
                        Q.push(My[v]);
                    }
                }
        }
        return dis!=INF;
    }
    bool DFS(int u)
    {
        for(int v=0; v<Ny; v++)
            if(!vst[v]&&g[u][v]&&dy[v]==dx[u]+1)
            {
                vst[v]=1;
                if(My[v]!=-1&&dy[v]==dis) continue;
                if(My[v]==-1||DFS(My[v]))
                {
                    My[v]=u;
                    Mx[u]=v;
                    return 1;
                }
            }
        return 0;
    }
    int MaxMatch()
    {
        int res=0;
        memset(Mx,-1,sizeof(Mx));
        memset(My,-1,sizeof(My));
        while(searchP())
        {
            memset(vst,0,sizeof(vst));
            for(int i=0; i<Nx; i++)
                if(Mx[i]==-1&&DFS(i))  res++;
        }
        return res;
    }
    
    int main()
    {
    #ifndef ONLINE_JUDGE
        freopen("in.txt","r",stdin);
    #endif // ONLINE_JUDGE
        int n,m,t,i,j;
        int T,iCase=0;
        scanf("%d",&T);
        while(T--)
        {
            iCase++;
            scanf("%d",&t);
            scanf("%d",&m);
            for(i=0; i<m; i++)
                scanf("%d%d%d",&guests[i].x,&guests[i].y,&guests[i].s);
            scanf("%d",&n);
            for(i=0; i<n; i++)
                scanf("%d%d",&um[i].x,&um[i].y);
            Nx=m;
            Ny=n;
            memset(g,0,sizeof(g));
            for(i=0; i<m; i++)
            {
                for(j=0; j<n; j++)
                {
                    if(distance(guests[i],um[j])/guests[i].s-t<eps)
                    {
                        g[i][j]=1;
                    }
                }
            }
            printf("Scenario #%d:
    %d
    
    ",iCase,MaxMatch());
        }
        return 0;
    }
  • 相关阅读:
    3D开发基础知识和简单示例
    六大设计原则详解
    InnoSetup 根据选择的安装语言显示不同语言的(协议)License和更新说明
    ASP.NET Core如何在.NET Core中构建和运行时禁用浏览器启动
    DevExpress 设置DateEdit显示年月季度
    DevExpress设置单元格不可编辑,选单元格则选中一行
    sql server数据库只有mdf文件,没有ldf,如何加载
    .net core 整洁架构入门
    在ASP.NET Core使用Entity Framework Core的日志显示sql语句
    在ASP.NET Core使用Entity Framework Core的日志
  • 原文地址:https://www.cnblogs.com/chenyang920/p/4392675.html
Copyright © 2011-2022 走看看