zoukankan      html  css  js  c++  java
  • HDU-5351

    MZL's Border

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 671    Accepted Submission(s): 209


    Problem Description
    As is known to all, MZL is an extraordinarily lovely girl. One day, MZL was playing with her favorite data structure, strings.

    MZL is really like Fibonacci Sequence, so she defines Fibonacci Strings in the similar way. The definition of Fibonacci Strings is given below.
      
      1) fib1=b
      
      2) fib2=a
      
      3) fibi=fibi1fibi2, i>2
      
    For instance, fib3=ab, fib4=aba, fib5=abaab.

    Assume that a string s whose length is n is s1s2s3...sn. Then sisi+1si+2si+3...sj is called as a substring of s, which is written as s[i:j].

    Assume that i<n. If s[1:i]=s[ni+1:n], then s[1:i] is called as a Border of s. In Borders of s, the longest Border is called as sLBorder. Moreover, s[1:i]'s LBorder is called as LBorderi.

    Now you are given 2 numbers n and m. MZL wonders what LBorderm of fibn is. For the number can be very big, you should just output the number modulo 258280327(=2×317+1).

    Note that 1T100, 1n103, 1m|fibn|.
     
    Input
    The first line of the input is a number T, which means the number of test cases.

    Then for the following T lines, each has two positive integers n and m, whose meanings are described in the description.
     
    Output
    The output consists of T lines. Each has one number, meaning fibn's LBorderm modulo 258280327(=2×317+1).
     
    Sample Input
    2
    4 3
    5 5
     
    Sample Output
    1
    2
     
    Source
    /**
         题意:给一个A串,一个B串,然后str[i] = str[i-1]+str[i-2];
                求解对于第n个串的第前m位最长的LBorder,LBorder 是指s[1:i]=s[n−i+1:n],
        做法:画几个串可以找到规律,比如第九个串
            a    b a   a b a    b a a b a   a b a b a a b  a    b a a  b  a a  b  a   b a  a  b  a
            [0] [0 1] [1 2 3]  [2 3 4 5 6] [4 5 6 7 8 9 10 11] [7 8 9 10 11 12 13 14 15 16 17 18 19]
            Java 
     **/
    import java.util.*;
    import java.math.*;
    
    public class Main 
    {
        public static void main(String args[]) 
        {
            BigInteger AA[] = new BigInteger [1000+5];
            BigInteger A[] = new BigInteger [1000+5];
            A[1] = BigInteger.ONE;
            A[2] = BigInteger.valueOf(2);
            BigInteger MOD = BigInteger.valueOf(258280327);
            BigInteger mm = BigInteger.valueOf(1);
            for (int i = 3; i <= 1001; i++) {
                A[i] = A[i-1].add(A[i-2]);
            }
            for(int i=2;i<=1001;i++)
            {
                A[i] = A[i].add(A[i-1]);
            }
            AA[1] = BigInteger.ZERO;
            AA[2] = BigInteger.ZERO;
            for(int i=3;i<=1001;i++)
            {
                AA[i] = AA[i-1].add(AA[i-2]).add(mm);
            }
            Scanner in = new Scanner(System.in);
            int t = in.nextInt();
            while (t-- > 0) 
            {
                int n = in.nextInt();
                BigInteger m = in.nextBigInteger();
                if (m.equals(BigInteger.valueOf(1)) || m.equals(BigInteger.valueOf(2)))
                {
                    System.out.println(0);
                    continue;
                }
                boolean ok = false;
                int tt = 0;
                for (int i = 1; i <= 1001; i++) 
                {
                  int yy = A[i].compareTo(m);
                  if(yy == 1) break;
                  tt = i;
                }
                if(A[tt].compareTo(m) == 0)
                {
                     BigInteger temp = BigInteger.ZERO;
                     BigInteger res = A[tt].subtract(A[tt-1]);
                     BigInteger tmp  = AA[tt].add(res) ;
                     tmp = tmp.subtract(mm);
                     System.out.println(tmp.mod(MOD));
                }
                else 
                {
                    BigInteger temp = BigInteger.ZERO;
                    BigInteger res = m.subtract(A[tt]);
                    BigInteger tmp  = AA[tt+1].add(res);
                    tmp = tmp.subtract(mm);
                    System.out.println(tmp.mod(MOD));
                }
              }   
        }
    }
  • 相关阅读:
    [OrangePi] Installation on SD Card
    网线直连笔记本玩树莓派
    vim多行缩进的方法
    对linux的根目录执行强制递归移除
    windows下快速启动 nginx 和 php-cgi 的两个批处理
    windows下nginx和php环境的配置
    c语言对文件操作完成后尽量手动关闭
    [记录]使用openGL显示点云的一个程序
    linux中使用软链接时出现 too many levels of symbolic links
    使用 nano 的时候提示找不到 libncursesw.so.5 这个共享库
  • 原文地址:https://www.cnblogs.com/chenyang920/p/4704088.html
Copyright © 2011-2022 走看看