zoukankan      html  css  js  c++  java
  • POJ-1509

    Time Limit: 3000MS   Memory Limit: 10000K
    Total Submissions: 3416   Accepted: 1940

    Description

    Once upon a time there was a famous actress. As you may expect, she played mostly Antique Comedies most of all. All the people loved her. But she was not interested in the crowds. Her big hobby were beads of any kind. Many bead makers were working for her and they manufactured new necklaces and bracelets every day. One day she called her main Inspector of Bead Makers (IBM) and told him she wanted a very long and special necklace. 

    The necklace should be made of glass beads of different sizes connected to each other but without any thread running through the beads, so that means the beads can be disconnected at any point. The actress chose the succession of beads she wants to have and the IBM promised to make the necklace. But then he realized a problem. The joint between two neighbouring beads is not very robust so it is possible that the necklace will get torn by its own weight. The situation becomes even worse when the necklace is disjoined. Moreover, the point of disconnection is very important. If there are small beads at the beginning, the possibility of tearing is much higher than if there were large beads. IBM wants to test the robustness of a necklace so he needs a program that will be able to determine the worst possible point of disjoining the beads. 

    The description of the necklace is a string A = a1a2 ... am specifying sizes of the particular beads, where the last character am is considered to precede character a1 in circular fashion. 

    The disjoint point i is said to be worse than the disjoint point j if and only if the string aiai+1 ... ana1 ... ai-1 is lexicografically smaller than the string ajaj+1 ... ana1 ... aj-1. String a1a2 ... an is lexicografically smaller than the string b1b2 ... bn if and only if there exists an integer i, i <= n, so that aj=bj, for each j, 1 <= j < i and ai < bi

    Input

    The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line containing necklace description. Maximal length of each description is 10000 characters. Each bead is represented by a lower-case character of the english alphabet (a--z), where a < b ... z.

    Output

    For each case, print exactly one line containing only one integer -- number of the bead which is the first at the worst possible disjoining, i.e. such i, that the string A[i] is lexicographically smallest among all the n possible disjoinings of a necklace. If there are more than one solution, print the one with the lowest i.

    Sample Input

    4
    helloworld
    amandamanda
    dontcallmebfu
    aaabaaa

    Sample Output

    10
    11
    6
    5

    Source

    /**
        题意:给一个串,求最小表示法
        做法:串的最小表示法
    **/
    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <string.h>
    #include <stdio.h>
    #include <queue>
    #include <map>
    #define maxn 10000 + 100
    using namespace std;
    int   match(string s)
    {
        int i, j, k, l;
        int N = s.length();
        s += s;
        for(i = 0, j = 1; j < N;)
        {
            for(k = 0; k < N && s[i + k] == s[j + k]; k++);
            if(k >= N) {
                break;
            }
            if(s[i + k] < s[j + k]) {
                j += k + 1;
            }
            else
            {
                l = i + k;
                i = j;
                j = max(l, j) + 1;
            }
        }
        return i;
        // cout << i << " --->" << min(i, j) << endl;
        //return s.substr(i, N);
        //  return min(i, j);
    }
    int main()
    {
        int T;
        scanf("%d", &T);
        while(T--)
        {
            int n;
            string str;
            string tmp;
            cin >> str;
            int   tt = match(str);
            cout << tt + 1 << endl;
        }
        return 0;
    }
  • 相关阅读:
    DLink无线路由器做交换机配置
    解决超过两小时的问题记录
    SIP学习之旅【资料收集篇】

    从google code里面获取代码的方法
    NSString表示的时间转为time_t
    C语言中 时间日期格式化符号 详解
    (转)time_t的定义
    (分享)简单圆角UITextView
    viewDidUnload释疑
  • 原文地址:https://www.cnblogs.com/chenyang920/p/4852588.html
Copyright © 2011-2022 走看看