zoukankan      html  css  js  c++  java
  • POJ 2752 Seek the Name, Seek the Fame

    Seek the Name, Seek the Fame
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 14875   Accepted: 7471

    Description

    The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

    Step1. Connect the father's name and the mother's name, to a new string S.
    Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

    Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

    Input

    The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

    Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

    Output

    For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

    Sample Input

    ababcababababcabab
    aaaaa
    

    Sample Output

    2 4 9 18
    1 2 3 4 5
    

    这个题目问的是保证前缀和后缀相同的情况下,求解这个前缀或后缀的长度。

    KMP的next值不就是该位前面的字符串中前缀后缀长度相同的位数么。

    我们只需要从最后面第len(len为字符串长度)开始找,找到一个前缀和后缀长度后,跳到前缀的后一个,继续把前缀作为处理的字符串继续找。直到最后到0.代码如下:

    /*************************************************************************
    	> File Name: Seek_the_Name.cpp
    	> Author: Zhanghaoran
    	> Mail: chilumanxi@xiyoulinux.org
    	> Created Time: Thu 26 Nov 2015 05:00:27 PM CST
     ************************************************************************/
    
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cstdio>
    #include <cstdlib>
    
    using namespace std;
    
    void prekmp(char x[], int m, int nextKmp[]){
        int i, j;
        i = 0;
        j = nextKmp[0] = -1;
        while(i < m){
            if(j == -1 || x[i] == x[j])
                nextKmp[++ i] = ++ j;
            else 
                j = nextKmp[j];
        }
        //for(int i = 0; i <= m; i ++)
        //    cout << nextKmp[i] << " ";
        //cout << endl;
    }
    
    int nexti[1000010];
    char a[1000010];
    int temp[1000010];
    int main(void){
        while(~scanf("%s", a)){
            int ans = 0;
            int len = strlen(a);
            prekmp(a, len, nexti);
            int p = len;
            temp[ans ++] = len;
            while(nexti[p]){
                p = nexti[p];
                temp[ans ++] = p;
            }
            for(int i = ans - 1; i >= 0; i --)
                cout << temp[i] << " ";
            cout << endl;
        }
    }


  • 相关阅读:
    C#中枚举的使用
    04 Spring的依赖注入
    03 Spring对Bean的管理
    02 Spring IOC
    01-Spring概述
    java8-方法引用
    java8-Stream
    java8-lambda
    centos中执行apt-get命令提示apt-get command not found
    Eclipse里git提交冲突rejected – non-fast-forward
  • 原文地址:https://www.cnblogs.com/chilumanxi/p/5136051.html
Copyright © 2011-2022 走看看