zoukankan      html  css  js  c++  java
  • POJ 2752 Seek the Name, Seek the Fame

    Seek the Name, Seek the Fame
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 14875   Accepted: 7471

    Description

    The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

    Step1. Connect the father's name and the mother's name, to a new string S.
    Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

    Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

    Input

    The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

    Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

    Output

    For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

    Sample Input

    ababcababababcabab
    aaaaa
    

    Sample Output

    2 4 9 18
    1 2 3 4 5
    

    这个题目问的是保证前缀和后缀相同的情况下,求解这个前缀或后缀的长度。

    KMP的next值不就是该位前面的字符串中前缀后缀长度相同的位数么。

    我们只需要从最后面第len(len为字符串长度)开始找,找到一个前缀和后缀长度后,跳到前缀的后一个,继续把前缀作为处理的字符串继续找。直到最后到0.代码如下:

    /*************************************************************************
    	> File Name: Seek_the_Name.cpp
    	> Author: Zhanghaoran
    	> Mail: chilumanxi@xiyoulinux.org
    	> Created Time: Thu 26 Nov 2015 05:00:27 PM CST
     ************************************************************************/
    
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cstdio>
    #include <cstdlib>
    
    using namespace std;
    
    void prekmp(char x[], int m, int nextKmp[]){
        int i, j;
        i = 0;
        j = nextKmp[0] = -1;
        while(i < m){
            if(j == -1 || x[i] == x[j])
                nextKmp[++ i] = ++ j;
            else 
                j = nextKmp[j];
        }
        //for(int i = 0; i <= m; i ++)
        //    cout << nextKmp[i] << " ";
        //cout << endl;
    }
    
    int nexti[1000010];
    char a[1000010];
    int temp[1000010];
    int main(void){
        while(~scanf("%s", a)){
            int ans = 0;
            int len = strlen(a);
            prekmp(a, len, nexti);
            int p = len;
            temp[ans ++] = len;
            while(nexti[p]){
                p = nexti[p];
                temp[ans ++] = p;
            }
            for(int i = ans - 1; i >= 0; i --)
                cout << temp[i] << " ";
            cout << endl;
        }
    }


  • 相关阅读:
    Scrapy 扩展中间件: 针对特定响应状态码,使用代理重新请求
    Scrapy 扩展中间件: 同步/异步提交批量 item 到 MySQL
    Scrapy 隐含 bug: 强制关闭爬虫后从 requests.queue 读取的已保存 request 数量可能有误
    Scrapyd 改进第二步: Web Interface 添加 STOP 和 START 超链接, 一键调用 Scrapyd API
    简单示例理解神闭包
    ejs 模板使用方法
    我使用的开源组件汇总,以备学习使用
    了不起的Node.js--之五 TCP连接
    Windows7下Java运行时环境搭建
    了不起的Node.js--之四
  • 原文地址:https://www.cnblogs.com/chilumanxi/p/5136051.html
Copyright © 2011-2022 走看看