zoukankan      html  css  js  c++  java
  • POJ 3087 Shuffle'm Up

    Shuffle'm Up
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 7429   Accepted: 3433

    Description

    A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

    The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

    The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

    After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

    For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

    Input

    The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

    Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

    Output

    Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

    Sample Input

    2
    4
    AHAH
    HAHA
    HHAAAAHH
    3
    CDE
    CDE
    EEDDCC

    Sample Output

    1 2
    2 -1


    这个题虽然kuangbin放在了搜索专题,但是还是觉得有点怪,没有用搜索方面的算法,只是把洗牌和发牌的过程写成函数,然后反复执行处理过程就可以,当出现重复的过程立刻退出返回-1即可。

    代码如下:

    /*************************************************************************
    	> File Name: Shufflem_Up.cpp
    	> Author: Zhanghaoran0
    	> Mail: chiluamnxi@gmail.com
    	> Created Time: 2015年07月29日 星期三 21时40分28秒
     ************************************************************************/
    
    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstring>
    
    using namespace std;
    
    int N;
    int c;
    char s1[101], s2[101], s12[202];
    
    void shuffle(char *s1, char *s2, char *s12){
        int i = 0, j = 0, k = 0;
        while(1){
            s12[i ++] = s2[j ++];
            s12[i ++] = s1[k ++];
            if(j == c && k == c){
            s12[i] = '';
             return ;
            }
        }
    }
    
    void change(char *s1, char *s2, char *s12){
        int i = 0, j = 0, k = 0;
        while(1){    
            if(i < c)
                s1[i ++] = s12[j ++];
            else 
                s2[k ++] = s12[j ++];
            if(k == c){
                s1[i] = '';
                s2[k] = '';
                return ;       
            }
        }
    }
    
    
    int main(void){
        cin >> N;
        int x = N;
        int ans;
        while(N -- ){
            cin >> c;
            cin >> s1;
            cin >> s2;
            cin >> s12;
            bool check = false;
            char temp1[101], temp2[101], temp12[202];
            ans = 0;
            strcpy(temp1, s1);
            strcpy(temp2, s2);
            strcpy(temp12, s12);
            while(1){
                shuffle(temp1, temp2, temp12);
                ans ++;
                if(!strcmp(temp12, s12)){
                    check = true;
                    break;
                }
                change(temp1, temp2, temp12);
                if(!strcmp(s1, temp1) && !strcmp(s2, temp2)){
                    break;
                }
            }
            if(check == true){
                cout << x - N << " " << ans << endl;
            }
            else 
                cout << x - N << " " << -1 << endl;
       }
    }


  • 相关阅读:
    POJ 3083 Children of the Candy Corn
    工程投诉过程中各建设主管理部门联系人表
    Csharp:ListView paging and groups from Any Data Sources
    Csharp: Listview convert Datatable and ListView.Group count
    Csharp:Windowsform using CheckedListBox Datasource
    jquery.jclock.js using different time zone offsets
    在请求和响应中使用 XML
    zindex属性简介
    谁是管理软件的优秀客户?
    知识管理项目简述
  • 原文地址:https://www.cnblogs.com/chilumanxi/p/5136097.html
Copyright © 2011-2022 走看看