zoukankan      html  css  js  c++  java
  • A Bug's Life(削弱版食物链)

    Description

    Background 
    Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
    Problem 
    Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

    Input

    The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

    Output

    The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

    Sample Input

    2
    3 3
    1 2
    2 3
    1 3
    4 2
    1 2
    3 4

    Sample Output

    Scenario #1:
    Suspicious bugs found!
    
    Scenario #2:
    No suspicious bugs found!

    Hint

    Huge input,scanf is recommended.





    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #include <iostream>
    using namespace std;
    const int maxn=2005;
    int par[maxn*2];
    
    void init(int n)
    {
        for(int i=0; i<=n; i++)
            par[i]=i;
    }
    
    int find(int x)
    {
        return par[x]==x?x:par[x]=find(par[x]);
    }
    
    void unite(int x,int y)
    {
        x=find(x);
        y=find(y);
        if(x==y)return;
        par[x]=y;
    }
    
    bool same(int x,int y)
    {
        return find(x)==find(y);
    }
    
    int main()
    {
        int T,tt=0,n,m;
        scanf("%d",&T);
        while(T--)
        {
            bool f=false;
            scanf("%d%d",&n,&m);
            init(n*2);
            while(m--)
            {
                int x,y;
                scanf("%d%d",&x,&y);
                if(same(x,y)||same(x+n,y+n))
                {
                    f=true;
                }
                else
                {
                    unite(x,y+n);
                    unite(x+n,y);
                }
            }
            printf("Scenario #%d:
    %s
    
    ",++tt,f?"Suspicious bugs found!":"No suspicious bugs found!");
        }
        return 0;
    }
    


  • 相关阅读:
    海量数据挖掘--DB优化篇
    BabyLinux制作过程详解
    C语言中的位域、字节序、比特序、大小端
    使用Busybox制作CRAMFS文件系统成功
    使用BusyBox制作linux根文件系统(CramFS+mdev)
    常用 U-boot命令详解
    基本C库函数
    simple_strtoul()
    在u-boot中添加命令
    U-Boot添加menu命令的方法及U-Boot命令执行过程
  • 原文地址:https://www.cnblogs.com/chinashenkai/p/9451411.html
Copyright © 2011-2022 走看看