zoukankan      html  css  js  c++  java
  • Catch That Cow

    Description

    Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

    * Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
    * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

    If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

    Input

    Line 1: Two space-separated integers: N and K

    Output

    Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

    Sample Input

    5 17

    Sample Output

    4

    Hint

    The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

    #include<cstdio>
    #include<iostream>
    #include<algorithm>
    #include<stdio.h>
    #include<queue>
    using namespace std;
    int n;
    typedef pair<int,int> tp;
    queue <tp> pp;
    int sn[200010]= {0};
    int bfs(int m,int s)
    {
        if(m>=n)
            return m-n;
        pp.push(tp(m,s));
        while(pp.size())
        {
            if(m<0) continue;
            tp p=pp.front();
            pp.pop();
            if(sn[p.first]==0)
            {
                sn[p.first] =1;
                if(p.first==n) return p.second;
                if(p.first+1<=1+n)
                    pp.push(tp(p.first+1,p.second+1));
                if(p.first-1<=1+n)
                    pp.push(tp(p.first-1,p.second+1));
                if(p.first*2<=1+n&&p.first!=0)
                    pp.push(tp(p.first*2,p.second+1));
            }
        }
        return 0;
    }
    int main()
    {
        int m;
        scanf("%d%d",&m,&n);
        printf("%d",bfs(m,0));
        return 0;
    }







  • 相关阅读:
    distributed caching for .net applications
    Linux_18/ mysql
    找到一本不错的Linux电子书,附《Linux就该这么学》章节目录。
    LinuxProbe/ 疑问ABC
    Linux_15/ autofs, DNS
    Linux_14/ SAMBA, NFS
    Linux_13/ 虚拟网站主机功能,Vsftpd
    Linux_12/ Apache, SELinux
    Linux_11/ firewalld-config, SSH, bounding
    Linux_10/ iptables & firewalld
  • 原文地址:https://www.cnblogs.com/chinashenkai/p/9451420.html
Copyright © 2011-2022 走看看