zoukankan      html  css  js  c++  java
  • How Many Tables HDOJ

    How Many Tables

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 52483    Accepted Submission(s): 26049

     

    Problem Description
    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
     

     

    Input
    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
     


    Output
    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
     


    Sample Input
    2 5 3 1 2 2 3 4 5 5 1 2 5
     


    Sample Output
    2 4
     
      典型的并查集题目,将树结构搞好以后就能得到tables
    Accept
    //    并查集
    
    import java.util.Scanner;
    
    public class Main{
        
        static int T;
        static int tree[];
        static int n;
        static int m;
        
        public static int findFather(int node){
            if(node!=tree[node]){
                return tree[node]=findFather(tree[node]);
            }
            return node;
        }
        
        public static void main(String args[]){
            
            Scanner reader=new Scanner(System.in);
            T=reader.nextInt();
            while(T>=1){
                n=reader.nextInt();
                m=reader.nextInt();
                tree=new int[n+1];
                
                for(int i=1;i<=n;i++){
                    tree[i]=i;
                }
                int max=n;
                for(int i=1;i<=m;i++){
                    int one=reader.nextInt();
                    int two=reader.nextInt();
                    int oneFather=findFather(one);
                    int twoFather=findFather(two);
                    if(oneFather!=twoFather){    //父结点不同
                        if(oneFather>twoFather){    //指向更大的结点
                            tree[twoFather]=oneFather;
                        }else{
                            tree[oneFather]=twoFather;
                        }
                        max--;
                    }
                }
                
                System.out.println(max);
                T--;
            }
        }
        
    }
  • 相关阅读:
    Lua大整数的实现
    std::allocator在stl容器中使用问题
    深度学习框架安装
    Tensorflow安装使用一段时间后,import时出现错误:ImportError: DLL load failed
    论文解读:SIFA
    多位微软MVP推荐,第一本ASP.NET Core 3.1的书来了
    ASP.NET Core 进程内与进程外的性能对比
    基于Netty的程序主动发送消息
    dbroot文件结构解析(一)
    qtree文件结构解析(二)
  • 原文地址:https://www.cnblogs.com/chiweiming/p/10704065.html
Copyright © 2011-2022 走看看