zoukankan      html  css  js  c++  java
  • 【POJ2387】Til the Cows Come Home (最短路)

    题面

    Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

    Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

    Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

    Input

    • Line 1: Two integers: T and N

    • Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

    Output

    • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

    Sample Input

    5 5
    1 2 20
    2 3 30
    3 4 20
    4 5 20
    1 5 100

    Sample Output

    90

    题解

    题目大意:给定N个点,T条边
    求出从节点1到节点N的最短路径长度。


    直接求最短路即可
    习惯用SPFA。。。
    如果用dijkstra要考虑重边的情况(舍掉之类的)

    #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #include<cmath>
    #include<queue>
    #include<algorithm>
    using namespace std;
    #define MAX 11000
    #define MAXL 22000
    struct Line
    {
         int v,next,w;
    }e[MAXL];
    int u,v,w; 
    int h[MAX],cnt=1;
    int T,N;
    queue<int> Q;
    
    bool vis[MAX];
    int dis[MAX];
    inline void Add(int u,int v,int w)
    {
    	 e[cnt]=(Line){v,h[u],w};
    	 h[u]=cnt++;
    }
    int main()
    {
    	 cin>>T>>N;
    	 for(int i=1;i<=T;++i)
    	 {
    	 	   cin>>u>>v>>w;
    	 	   Add(u,v,w);
    	 	   Add(v,u,w);
    	 }
    	 for(int i=1;i<=N;++i)
    	       dis[i]=1050000000;
    	 /*********SPFA***********/
    	 vis[1]=true;dis[1]=0;
    	 Q.push(1);
    	 while(!Q.empty())
    	 {
    	 	    u=Q.front();Q.pop();
    	 	    vis[u]=false;
    	 	    for(int i=h[u];i;i=e[i].next)
    	 	    {
    	 	    	   v=e[i].v;
    	 	    	   if(dis[v]>dis[u]+e[i].w)
    	 	    	   {
    	 	    	   	      dis[v]=dis[u]+e[i].w;
    	 	    	   	      if(!vis[v])
    	 	    	   	      {
    	 	    	   	      	   vis[v]=true;
    	 	    	   	      	   Q.push(v);
    	 	    	   	      }
    	 	    	   }
    	 	    }
    	 }
    	 cout<<dis[N]<<endl;
    	 return 0;
    }
    
  • 相关阅读:
    web service 项目 和 普通 web项目 的 区别
    1) Apache Maven 's README.txt
    spring + rs + RocketMQ 【精】
    wadl 的自动生成(cxf版本3.1.1)
    新建maven web 项目后,出现的小问题
    cxf-rs client 调用
    wadl 的自动生成(cxf版本2.7.6)
    Java学习路线
    Tomcat 学习记录
    Spring Boot 学习记录
  • 原文地址:https://www.cnblogs.com/cjyyb/p/7237109.html
Copyright © 2011-2022 走看看